MPL Compliance: Add MPL headers or Initial Developer sections

RESOLVED FIXED in Bugzilla 4.4

Status

()

--
enhancement
RESOLVED FIXED
12 years ago
7 years ago

People

(Reporter: mkanat, Assigned: LpSolit)

Tracking

unspecified
Bugzilla 4.4

Details

(Reporter)

Description

12 years ago
All MPL license blocks at the beginning of files must list an "Original Developer." I didn't know this, and I started the bad trend of not including it in files.

  http://www.mozilla.org/MPL/MPL-1.1-annotated.html

  Section 2 is the relevant section.

  This could easily be done by parsing out dates and names from checkin comments, if somebody feels adventurous and wants to do that.
(Reporter)

Updated

12 years ago
Whiteboard: [Good Intro Bug]
(Assignee)

Updated

11 years ago
Duplicate of this bug: 411328
(Assignee)

Comment 2

11 years ago
Those have no license at all:
editmilestones.cgi
t/Support/Systemexec.pm
skins/standard/show_multiple.css
skins/standard/params.css
skins/standard/panel.css

Those have a BSD license:
js/yui/calendar.js
js/yui/yahoo-dom-event.js
skins/standard/yui/calendar.css

This one is in contrib/ so I have no idea if it needs one or not:
contrib/sendbugmail.pl

Those have none as well, but are also in contrib/ so I have the same question as above:
skins/contrib/Dusk/*.css

Franck?
> Those have none as well, but are also in contrib/ so I have the same question
> as above:
> skins/contrib/Dusk/*.css

The original ones here have a license (there is only one, global.css). The others aren't part of the distribution because they're being generated by checksetup.pl.
(Reporter)

Comment 4

11 years ago
YUI files have the Yahoo license, not a BSD license. They should not be changed, as we do not own them. The Yahoo license is compatible with the MPL, so there's nothing wrong there.
(Assignee)

Comment 5

11 years ago
(In reply to comment #4)
> YUI files have the Yahoo license, not a BSD license. They should not be
> changed, as we do not own them. The Yahoo license is compatible with the MPL,
> so there's nothing wrong there.
> 

I can read:

Copyright (c) 2007, Yahoo! Inc. All rights reserved.
Code licensed under the BSD License:
http://developer.yahoo.net/yui/license.txt
version: 2.3.1
(Reporter)

Comment 6

11 years ago
Ahh, I guess you're right. I thought I read something about them having their own license, but I guess not! :-)
(Assignee)

Comment 7

11 years ago
(In reply to comment #5)
> Code licensed under the BSD License:

Is BSD a problem or not? I know nothing about license issues (nor what you can do and cannot do with them), that's why I'm asking. :)
(Reporter)

Comment 8

11 years ago
BSD is not a problem.

Comment 9

11 years ago
(In reply to comment #0)
> All MPL license blocks at the beginning of files must list an "Original
> Developer." I didn't know this, and I started the bad trend of not including it
> in files.
>   http://www.mozilla.org/MPL/MPL-1.1-annotated.html
>   Section 2 is the relevant section.
>   This could easily be done by parsing out dates and names from checkin
> comments, if somebody feels adventurous and wants to do that.

Hello Max,

I feel adventurous enough but would need to know where the text is, which would need to be inserted.  I'd need also a copy of a correct license to compare to the incorrect ones, etc.  I can do this, just need this input / data to do it.

Mike
(Reporter)

Updated

10 years ago
Duplicate of this bug: 477683
(Reporter)

Comment 11

10 years ago
Here's my comment from the dup bug:

There are some files in Bugzilla that are entirely missing an MPL license
header. If you know the original authors of these files, please CC them on this
bug. They must either grant the license here in writing or add the header to
the files themselves (and so must anybody else who has ever touched the file).

A good example file with a correct format for this header is here:

  http://mxr.mozilla.org/mozilla/source/webtools/bugzilla/Bugzilla/JobQueue.pm

Of course, please replace "Mozilla Corporation" with the name of yourself (if
you wrote this on your own time) or the name of your company (if you wrote this
on company time--and make sure that your legal department actually does grant
this license).

The files with missing headers are:

contrib/bugzilla_ldapsync.rb
contrib/bugzilla-submit/bugzilla-submit
contrib/cmdline/*
contrib/gnatsparse/*
contrib/yp_nomail.sh
extensions/example/template/en/global/user-error-errors.html.tmpl
skins/standard/panel.css
skins/standard/params.css
skins/standard/show_bug.css
skins/standard/show_multiple.css

There are more files that are missing the Initial Developer block, which must
be added by the original developer (please CC them if you know who they are) or
the grant must be noted here in this bug in writing so that somebody else can
write the patch:

Bugzilla/Attachment/PatchReader.pm
Bugzilla/Auth/Login/Cookie.pm
Bugzilla/Auth/Verify/Stack.pm
Bugzilla/Auth/Verify.pm
Bugzilla/Auth/Login.pm
Bugzilla/Install/Filesystem.pm
Bugzilla/Install/DB.pm
Bugzilla/Install/Requirements.pm
Bugzilla/Install/Requirements.pm.orig
Bugzilla/Search/Quicksearch.pm
Bugzilla/User/Setting/Skin.pm
Bugzilla/User/Setting.pm
Bugzilla/WebService/Bugzilla.pm
Bugzilla/WebService/Bug.pm
Bugzilla/WebService/Constants.pm
Bugzilla/WebService/User.pm
Bugzilla/WebService/Product.pm
Bugzilla/WebService/Bug.pm.orig
Bugzilla/Component.pm
Bugzilla/Classification.pm
Bugzilla/Product.pm
Bugzilla/Field.pm
Bugzilla/Install.pm
Bugzilla/Keyword.pm
Bugzilla/Milestone.pm
Bugzilla/Update.pm
Bugzilla/Version.pm
Bugzilla/WebService.pm
contrib/bz_webservice_demo.pl
contrib/sendbugmail.pl
editfields.cgi
editsettings.cgi
editusers.cgi
editvalues.cgi
mod_perl.pl
search_plugin.cgi
sidebar.cgi
skins/standard/create_attachment.css
skins/standard/editusers.css
skins/standard/index.css
skins/standard/panel.css
skins/standard/params.css
skins/standard/show_bug.css
skins/standard/show_multiple.css
skins/standard/summarize-time.css
skins/standard/voting.css
skins/standard/IE-fixes.css
summarize_time.cgi
t/Support/Systemexec.pm
t/010dependencies.t
t/011pod.t
template/en/default/account/email/confirm-new.html.tmpl
template/en/default/account/email/request-new.txt.tmpl
template/en/default/account/prefs/settings.html.tmpl
template/en/default/welcome-admin.html.tmpl
template/en/default/admin/custom_fields/create.html.tmpl
template/en/default/admin/custom_fields/edit.html.tmpl
template/en/default/admin/custom_fields/list.html.tmpl
template/en/default/admin/custom_fields/confirm-delete.html.tmpl
template/en/default/admin/fieldvalues/confirm-delete.html.tmpl
template/en/default/admin/fieldvalues/create.html.tmpl
template/en/default/admin/fieldvalues/edit.html.tmpl
template/en/default/admin/fieldvalues/footer.html.tmpl
template/en/default/admin/fieldvalues/list.html.tmpl
template/en/default/admin/fieldvalues/select-field.html.tmpl
template/en/default/admin/products/groupcontrol/updated.html.tmpl
template/en/default/admin/products/confirm-delete.html.tmpl
template/en/default/admin/products/create.html.tmpl
template/en/default/admin/products/edit-common.html.tmpl
template/en/default/admin/products/edit.html.tmpl
template/en/default/admin/products/footer.html.tmpl
template/en/default/admin/products/list-classifications.html.tmpl
template/en/default/admin/products/list.html.tmpl
template/en/default/admin/settings/edit.html.tmpl
template/en/default/admin/users/confirm-delete.html.tmpl
template/en/default/admin/users/create.html.tmpl
template/en/default/admin/users/edit.html.tmpl
template/en/default/admin/users/list.html.tmpl
template/en/default/admin/users/listselectvars.html.tmpl
template/en/default/admin/users/search.html.tmpl
template/en/default/admin/users/userdata.html.tmpl
template/en/default/admin/users/responsibilities.html.tmpl
template/en/default/admin/admin.html.tmpl
template/en/default/admin/workflow/comment.html.tmpl
template/en/default/admin/workflow/edit.html.tmpl
template/en/default/attachment/confirm-delete.html.tmpl
template/en/default/attachment/delete_reason.txt.tmpl
template/en/default/bug/summarize-time.html.tmpl
template/en/default/global/per-bug-queries.html.tmpl
template/en/default/global/setting-descs.none.tmpl
template/en/default/global/textarea.html.tmpl
template/en/default/global/userselect.html.tmpl
template/en/default/pages/quicksearch.html.tmpl
template/en/default/pages/quicksearchhack.html.tmpl
template/en/default/reports/old-charts.html.tmpl
template/en/default/reports/report-simple.html.tmpl
template/en/default/search/search-plugin.xml.tmpl
testagent.cgi
testserver.pl
userprefs.cgi
xmlrpc.cgi
Summary: Lots of Bugzilla code missing the "Original Developer" block in the license block → MPL Compliance: Add MPL headers or Initial Developer sections
And here's mine, most of which is also applicable to this bug:

> If you know the original authors of these files, please CC them on this
> bug. They must either grant the license here in writing or add the header to
> the files themselves (and so must anybody else who has ever touched the file).

That's just simply not true. These files are MPLed just like the rest of
Bugzilla, and I don't think you'd find a court that said otherwise. After all,
under what terms have we been distributing them and everyone been using them
for the years they've existed, if not those terms?

There are hundreds, possibly thousands of files in the Mozilla source tree
without license headers, and it's not a cause of stress for anyone. If you
would like to add license headers to all the files you list above, feel free.
That would be a great thing to do (and it requires a little research to fill in
the headers properly). But please don't imply that there's a licensing problem
until we do this, because there isn't.

However, please do not copy licenses from existing files. The license pages on
www.mozilla.org say specifically not to do that. Instead, please use the
boilerplate headers here:
http://www.mozilla.org/MPL/boilerplate-1.1/

Perhaps emailing licensing@mozilla.org might have been a good first step in
looking into this question? :-)

Gerv
(Reporter)

Comment 13

10 years ago
(In reply to comment #12)
> That's just simply not true. These files are MPLed just like the rest of
> Bugzilla, and I don't think you'd find a court that said otherwise. After all,
> under what terms have we been distributing them and everyone been using them
> for the years they've existed, if not those terms? [snip]

  Ah, that's great to know! :-) That makes things much simpler.
 
> Please don't imply that there's a licensing problem
> until we do this, because there isn't.

  Well, the Committer's Agreement that I just signed says that I have to be in compliance with the license for code I've committed, and the license seems to require that I put that block at the top of each file. I assume other committers are bound similarly.

  It's good to know that there is no legal problem with this, though, that's relieving. :-)

> However, please do not copy licenses from existing files. The license pages on
> www.mozilla.org say specifically not to do that. Instead, please use the
> boilerplate headers here:
> http://www.mozilla.org/MPL/boilerplate-1.1/

  Thanks. :-) For Bugzilla, usually the most appropriate one would be this one (since we don't use the tri-license):

  http://www.mozilla.org/MPL/boilerplate-1.1/mpl-sh
Severity: normal → enhancement
(In reply to comment #13)
>   Well, the Committer's Agreement that I just signed says that I have to be in
> compliance with the license for code I've committed, and the license seems to
> require that I put that block at the top of each file. I assume other
> committers are bound similarly.

They are; but if files magically appear all on their own without the headers, it's not a big deal. ;-)

>   Thanks. :-) For Bugzilla, usually the most appropriate one would be this one
> (since we don't use the tri-license):
> 
>   http://www.mozilla.org/MPL/boilerplate-1.1/mpl-sh

Right. :-)

Gerv
Depends on: 680131
(Assignee)

Comment 15

7 years ago
Fixed when switching to MPL 2.0.
Assignee: general → LpSolit
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Whiteboard: [Good Intro Bug]
Target Milestone: --- → Bugzilla 4.4
You need to log in before you can comment on or make changes to this bug.