If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Read-only files in DE 2.0.0.2 RC2 - \defaults\profile

RESOLVED FIXED

Status

Mozilla Localizations
de / German
--
blocker
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Tomcat, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({verified1.8.0.10, verified1.8.1.2})

unspecified
x86
All
verified1.8.0.10, verified1.8.1.2
Bug Flags:
blocking1.8.1.2 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
During a check from the DE Build from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2.0.0.2-candidates/rc2/firefox-2.0.0.2.de.win32.installer.exe i noticed that the files in \defaults\profile\ are read-only again.

Reproduced on Windows 2000 SP4 and XP Sp2

When you create a new profile the profile files are not read-only, so bookmarks and toolbar customizations will be saved (so its not the same as in the 2001 Build), but i think we should change the files in \defaults\profile\ also.
Flags: blocking1.8.1.2?

Comment 1

11 years ago
I don't see a reason for this in CVS, maybe the release team can help.
(Reporter)

Comment 2

11 years ago
This seems to be (again?) only a problem with the DE Build, i checked the en-US Build and the FI build as reference and they have no read-only files on \defaults\profile\
Is it expected that the build log for win32 2.0.0.2 de [1] should be saying

/cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n-release/WINNT_5.2_Depend/mozilla/build/cygwin-wrapper /cygdrive/c/moztools/bin/nsinstall /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n-release/WINNT_5.2_Depend/mozilla/../l10n/de/browser/profile/bookmarks.html /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n-release/WINNT_5.2_Depend/mozilla/../l10n/de/browser/profile/localstore.rdf /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n-release/WINNT_5.2_Depend/mozilla/../l10n/de/browser/profile/search.rdf /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n-release/WINNT_5.2_Depend/mozilla/../l10n/de/browser/profile/win/mimeTypes.rdf ../../dist/xpi-stage/locale-de/defaults/profile

If I'm reading attachment 250479 [details] [diff] [review] from bug 364599 correctly, shouldn't it be using "... nsinstall -t -m 644 ...". The variable expansions are [2,3] AFAICT.

[1] http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla1.8-l10n-de/1171326240.1171327930.19326.gz&fulltext=1
[2] http://lxr.mozilla.org/mozilla1.8/source/config/config.mk#839 - SYSINSTALL
[3] http://lxr.mozilla.org/mozilla1.8/source/config/rules.mk#532 - IFLAGS1

Comment 4

11 years ago
I reopened bug 364599, the attachement cf linked was never checked in on the branches.
Flags: blocking1.8.1.2? → blocking1.8.1.2+
Assignee: kairo → sspitzer
Looks like Seth just checked this in (in bug 364599)
Keywords: fixed1.8.0.10, fixed1.8.1.2
nick, thanks for your comment #3.  I checked, and from http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla1.8-l10n-de/1171435080.1171435663.27346.gz&fulltext=1, we have:

/cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n/WINNT_5.2_Clobber/mozilla/build/cygwin-wrapper /cygdrive/c/moztools/bin/nsinstall -t -m 644 /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n/WINNT_5.2_Clobber/mozilla/../l10n/de/browser/README.txt ../../dist/xpi-stage/locale-de
/cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n/WINNT_5.2_Clobber/mozilla/build/cygwin-wrapper /cygdrive/c/moztools/bin/nsinstall -t -m 644 /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n/WINNT_5.2_Clobber/mozilla/../l10n/de/browser/profile/bookmarks.html /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n/WINNT_5.2_Clobber/mozilla/../l10n/de/browser/profile/localstore.rdf /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n/WINNT_5.2_Clobber/mozilla/../l10n/de/browser/profile/search.rdf /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n/WINNT_5.2_Clobber/mozilla/../l10n/de/browser/profile/win/mimeTypes.rdf ../../dist/xpi-stage/locale-de/defaults/profile
/cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n/WINNT_5.2_Clobber/mozilla/build/cygwin-wrapper /cygdrive/c/moztools/bin/nsinstall -t -m 644 /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n/WINNT_5.2_Clobber/mozilla/../l10n/de/browser/profile/chrome/userChrome-example.css /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n/WINNT_5.2_Clobber/mozilla/../l10n/de/browser/profile/chrome/userContent-example.css ../../dist/xpi-stage/locale-de/defaults/profile/chrome
/cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n/WINNT_5.2_Clobber/mozilla/build/cygwin-wrapper /cygdrive/c/moztools/bin/nsinstall -t -m 644 /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n/WINNT_5.2_Clobber/mozilla/browser/locales/en-US/searchplugins/google.xml /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n/WINNT_5.2_Clobber/mozilla/../l10n/de/browser/searchplugins/yahoo-de.xml /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n/WINNT_5.2_Clobber/mozilla/../l10n/de/browser/searchplugins/amazondotcom-de.xml /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n/WINNT_5.2_Clobber/mozilla/../l10n/de/browser/searchplugins/eBay-de.xml /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-l10n/WINNT_5.2_Clobber/mozilla/../l10n/de/browser/searchplugins/wikipedia-de.xml ../../dist/xpi-stage/locale-de/searchplugins

note, this is after my fix.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
I guess this could have been a duplicate of bug #364599.

so, since the watch problem has been there all along, this should mean that all the de linux 1.5.0.10 nightlies and the all the de windows 2.0.0.2 nightlies had this issue.

but, if it was a build that also contained my other patches for bug #367084 and bug #364599, it wouldn't not have been detectable by the end user (unless you looked at the files on disk).
(Reporter)

Comment 8

11 years ago
Verified fixed for 1.8.1.2 and 1.8.0.10 with Windows 1.8.1.2 RC4 Sign-test / 1.8.1.2 Linux Build also on 1.8.0.10 Linux RC 2 Build
Keywords: fixed1.8.0.10, fixed1.8.1.2 → verified1.8.0.10, verified1.8.1.2
You need to log in before you can comment on or make changes to this bug.