"Check for Updates" tries to update Firefox despite a restricted user account and fails ungracefully

RESOLVED DUPLICATE of bug 383518

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 383518
12 years ago
10 years ago

People

(Reporter: Ilja Sekler, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2pre) Gecko/20070206 BonEcho/2.0.0.2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2pre) Gecko/20070206 BonEcho/2.0.0.2pre

Since the fix for Bug 351949 the feature "Check for Updates" is not more greyed out if Firefox/Bon Echo is being run by a restricted user on Windows XP. If a newer version is available, it downloads the update, tries to install it and fails, showing an error message.

The updater should check (again) first, whether Firefox has a write access to its application directory. Might affect also W2K.

Reproducible: Always

Steps to Reproduce:
1. Install a Firefox branch build > 20070205.
2. Log on as a restricted user, run Firefox.
3. Let it check for updates, click on "Download and install now" and then on "Restart Bon Echo now".
Actual Results:  
Firefox attempts to install the update, shows an error message upon restart.

Expected Results:  
If there are any updates available, Firefox prompts the user to run it with administrative privileges and doesn't download the update itself if it may not install it successfully.
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0 Branch

Comment 1

11 years ago
This problem is now also reproducible with Firefox 2.0.0.3. 
This event is being reported on IRC channel going from 2.0.0.3 to 2.0.0.4 on a restricted user account causing the update to fail. 

Also reported here: http://forums.mozillazine.org/viewtopic.php?t=553639

See also: https://bugzilla.mozilla.org/show_bug.cgi?id=303595 as being the same issue I think.  

Updater either needs changed to run no matter what user priv's, or set to alert that an "update is available to install you must use an admin account/priv's."
Flags: blocking1.8.0.13?
Flags: blocking1.8.0.13? → blocking1.8.1.5?

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 383518
Flags: blocking1.8.1.5?
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.