In Advanced/General/Choose "en-US" (set via intl.accept_languages) is not match to "en-us"

RESOLVED FIXED in seamonkey2.1a3

Status

SeaMonkey
Preferences
--
trivial
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: bugzilla2005, Assigned: Philip Chee)

Tracking

Trunk
seamonkey2.1a3

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.1.1) Gecko/20061221 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.1.1) Gecko/20061221 Firefox/2.0.0.1

Advanced/General/Choose does not perform language tag matching in a case-insensitive manner: It does, e.g., not match "en-US" (set via intl.accept_languages) to "en-us (English/United States)"; instead, it simly displays "en-US" without the explanatory "(English/United States)" text.

But language tags are case-insensitive -- and uppercase country subtags are actually preferred (FWIW: maybe you could follow this convention as well.)

Reproducible: Always

Steps to Reproduce:
1. Set (using about:config) "intl.accept_languages" to "en-US"
2. Open Preferences/Advanced/General/Choose...

Actual Results:  
The "languages in order of prefernece" list now contains an "en-US" entry 

Expected Results:  
I would have expected to see either "en-US (English/United States)" or "en-us (English/United States)", since language tags are case-insensitive and hence a match for "en-US" ought to be found.

I stumbled upon this problem when manually setting intl.accept_languages to include de-DE-1901 as well; doing that I also normalized the country subtags to uppercase.

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Solaris → All
Hardware: Sun → All
Created attachment 255204 [details] [diff] [review]
Patch
Assignee: nobody → smontagu
Status: NEW → ASSIGNED
Attachment #255204 - Flags: review?(mano)
(In reply to comment #0)
> But language tags are case-insensitive -- and uppercase country subtags are
> actually preferred (FWIW: maybe you could follow this convention as well.)

This was suggested in bug 44063 and resolved INVALID. I may reconsider it in bug 356038.
Comment on attachment 255204 [details] [diff] [review]
Patch

r=mano
Attachment #255204 - Flags: review?(mano) → review+
Checked in. Keeping the bug open for suite.
Reducing severity, since in suite you can add languages from the preferences UI without resorting to about:config, and that scenario doesn't have the bug.
Assignee: smontagu → prefs
Severity: minor → trivial
Status: ASSIGNED → NEW
Component: Preferences → Preferences
Product: Firefox → Mozilla Application Suite
QA Contact: preferences
Version: unspecified → Trunk
(Filter "spam" on 'prefs-nobody-20080612'.)
Assignee: prefs → nobody
QA Contact: prefs
(Assignee)

Comment 7

7 years ago
Created attachment 458599 [details] [diff] [review]
Patch Sv1.0 Suite fix.

> Simon Montagu      2007-02-15 08:42:15 PST
> 
> Checked in. Keeping the bug open for suite.
Fix Suite (finally).
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #458599 - Flags: superreview?(neil)
Attachment #458599 - Flags: review?(iann_bugzilla)

Updated

7 years ago
Attachment #458599 - Flags: superreview?(neil)
Attachment #458599 - Flags: superreview+
Attachment #458599 - Flags: review?(iann_bugzilla)
Attachment #458599 - Flags: review+
(Assignee)

Comment 8

7 years ago
Pushed to comm-central.
http://hg.mozilla.org/comm-central/rev/0297879cb2d2
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Target Milestone: --- → seamonkey2.1a3
You need to log in before you can comment on or make changes to this bug.