Closed Bug 370450 Opened 16 years ago Closed 5 years ago

Safari "canvas" demonstration cause Minefield to hang while page is loaded

Categories

(Core :: Graphics: Canvas2D, defect)

defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: phazon, Unassigned)

Details

(Keywords: hang, perf, Whiteboard: DUPEME)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070214 Minefield/3.0a3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070214 Minefield/3.0a3pre

Minefield hangs during page load. No additional info except that is canvas demo.

Reproducible: Always

Steps to Reproduce:
1.Go to http://undefined.org/js/canvas0000.html
2.Just load page
3.
Actual Results:  
Browser hangs

Expected Results:  
seeing canvas demo?
Loads fine here. A little slow but then that'll be the long running code.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a3pre) Gecko/20070213 Minefield/3.0a3pre ID:2007021304 [cairo]
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a5pre) Gecko/20070529 Minefield/3.0a5pre

Caused Minefield to hang for roughly 30 seconds before opening properly.
Happens for each OS. IMO there should already be a bug about a hang while loading a page. Confirming this one meanwhile.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: hang
OS: Windows XP → All
Hardware: PC → All
Summary: Safari "canvas" demonstration cause Minefield to hang → Safari "canvas" demonstration cause Minefield to hang while page is loaded
Whiteboard: DUPEME
Version: unspecified → Trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090925 Shiretoko/3.5.4pre GTB5

I got the same result as Comment #2 plus a dozen of "Unresponsive Script" warnings.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100211 Minefield/3.7a2pre

Same result as https://bugzilla.mozilla.org/show_bug.cgi?id=370450#c2 and https://bugzilla.mozilla.org/show_bug.cgi?id=370450#c4
Not clear to me that there's anything actionable here, I guess someone could profile...
Component: General → Canvas: 2D
Product: Firefox → Core
No longer cause any hangs.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.