Loading an OpenSearch Description directly should offer to install

RESOLVED WONTFIX

Status

()

Firefox
Search
RESOLVED WONTFIX
11 years ago
5 years ago

People

(Reporter: philor, Unassigned)

Tracking

Trunk
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
Loading an OpenSearch Description file served as application/opensearchdescription+xml (like <http://dev.philringnalda.com/opensearch/foo.xml>) should offer to install the search engine (and, ideally, then pass the content on to the XML prettyprinter for display, in case that's what you really wanted to do), rather than asking you what to do with that thing "which is a: Extensible Markup Language."

Along with the benefit to users, of not getting a baffling dialog, that would make it possible to do links the right way, <a href="desc.xml" onclick="add(this.href); return false;">, offering the best possible experience for people with JavaScript enabled, but degrading nicely with full function for those with it disabled.
Flags: blocking-firefox3?
Is this really a common use-case? I don't think it's a blocker, but definitely a wanted. Robert Sayrer might be able to help here.
Flags: blocking-firefox3? → blocking-firefox3-
Whiteboard: [wanted-firefox3]
(Reporter)

Comment 2

11 years ago
Well, it's as common as browsing with JavaScript disabled (and I see that NoScript is the number two extension, by popularity).

I'm surprised I didn't mention the impetus for filing in comment 0 - the STR are:

1. Disable JavaScript.
2. Visit https://addons.mozilla.org/en-US/firefox/browse/type:4
3. Reading fine print is for suckers: scroll down to the bottom, and click the LinkedIn link.

Expected: get a LinkedIn search engine.
Actual: scroll to the top of the page.

AMO could be doing better (script-only links with href="#" are actually even worse than the horror of href="javascript:foo()" links), but I don't think they *can* actually do well right now - the best idea I've had is autodiscovery <link>s that are then removed with JavaScript, with a <noscript> explanation to either enable JS or scroll through the 21 items in the searchbar popup, but since we don't actually listen for DOMLinkRemoved, that wouldn't work either. 

However, if we have a handler for application/opensearchdescription+xml, they can do the right thing, <a href="http://amo/thisengine.xml" onclick="addEngine(this); return false;">, and have JS, no-JS, copy-paste, open in new tab, send this link, every sort of link behavior work perfectly.

Comment 3

11 years ago
I agree that this is a bug. Definitely not a blocker.
Flags: wanted-firefox3+
Whiteboard: [wanted-firefox3]
(Reporter)

Updated

10 years ago
Duplicate of this bug: 438056
As I written in Bug 438056, currently search plugins can't be installed from the local as extensions too.
Not a common enough use case to be worth the effort, I think.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.