Natural language navigation

RESOLVED DUPLICATE of bug 393508

Status

()

Firefox
Address Bar
--
enhancement
RESOLVED DUPLICATE of bug 393508
12 years ago
11 years ago

People

(Reporter: Ivan Ičin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME? or INVALID if too many in one bug)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2) Gecko/20070206 GranParadiso/3.0a2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2) Gecko/20070206 GranParadiso/3.0a2

URLs are not user-friendly. Search is much more natural way of navigation. This means that user shouldn't bother to think of URLs, but just to type in what he wants, and URL should retrive information from search engine, bookmarks and history, and show it in the drop down box.

Of course, if someone puts URL in such box (which should change address bar), it should be easily recognizable, and Firefox should go to exact that address.

I really prefer such way of navigating the Internet when I visit the site that I am sure to be on top of Google's results. That is mostly in the case when it is some brand name, institution, etc... Unfortunatly it doesn't work for the sites I visit frequently, so I must remember their URLs and sort through them, which is far from necessary.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

12 years ago
And here is a starting solution point (taken from my blog http://features20.blogspot.com):

This is feature that your next browser should have. You are probably very well aware that web site addresses (aka as URL) are not user friendly. Using URLs is exactly like asking people to learn MS-DOS commands to handle files.

Most people are not aware of even single URL. In reality people are only aware of brand names, so if www. + brand name + .com works everything is fine, if it doesn't then there is trouble. And if one is after some specific page, which might be: https://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox, situation is more or less helpless.

So let's switch to my father. He navigates the Internet by typing in what he wants to find in search box of a browser, and then he selects page he wants to go to from search results. It is very intuitive, almost always works, and everyone can learn within seconds. Still there is a problem with this type of navigation in today's browsers - this is thought to be only second way of navigating, which means it is far from productive, and fairly unsupported.

So, let's ditch both address and search bar from your browser and keep just one box that handles both thing: Access bar. It should act like following:


   1. Drop down of address bar should show on its top several pages that are visited, whose title (or better whole content) matches phrase in access bar, and they should be ordered by frequency of visit, it should be possible to expand list if necessary;

   2. Next section should be devoted to top search engine results, which should be also expandable (and there should be general option to show both title and text description);

   3. Finally, there should be several search engines listed, to do full search with keywords in Access bar (and this part should be also expandable);

   4. It should be easy to recognize if someone types in URL, as every single word processor does this, and in this case browser should go to exactly that address.

One should also note that browser must provide solution to mix search results with sponsored search in search results section, as it is highly unlikely that this would be implemented otherwise, as it would have negative commercial effects.

Updated

11 years ago
Whiteboard: DUPEME? or INVALID if too many in one bug
(Reporter)

Comment 2

11 years ago
Created attachment 271285 [details]
mockup

I made a mockup with possible solution.

Also, thinking a bit more, this doesn't require removal of search bar, those elements may be complement.
(Reporter)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 393508
You need to log in before you can comment on or make changes to this bug.