Fonts are not properly rendered on OSX/PPC

VERIFIED DUPLICATE of bug 288047

Status

VERIFIED DUPLICATE of bug 288047
12 years ago
12 years ago

People

(Reporter: juanjose.garciaripoll, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1a3) Gecko/20060629 Camino/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1a3) Gecko/20060629 Camino/1.0+

I experienced this bug with Firefox 2.0.0.1 and I am seeing it, to a lesser degree in nightly builds of Camino. I did not appreciate the problem with Firefox pre3.0

Basically, Gecko does not seem to get the size of letters right when a sentence mixes italic/bold and ordinary charcters. Words appear overlapped.

Reproducible: Always

Steps to Reproduce:
1.Open webpage above
2.Look for a word in italic or bold
3.
Actual Results:  
The spacing between ordinary and italic/bold characters is not properly rendered. Words overlap, making it difficult to read the text.
(Reporter)

Comment 1

12 years ago
Created attachment 255361 [details]
Screenshot of Camino showing an improperly rendered page

Look for the italic word to see the wrong rendering
You're running a version of Camino that's 8 months old; does the problem persist in Camino 1.1a2 (http://beta.caminobrowser.org)?

Are you running 10.4?

Comment 3

12 years ago
dupe of bug 288047 ?

Juan, could you verify that
1/ you have the following fonts: 'Georgia' and 'Times New Roman' installed in both ~/Library/Fonts and /Library/Fonts ?
2/ if you remove or disable the ones in ~/Library/Fonts, then restart the browser, does the problem still happen?

You can use FontBook.app to do all this.
(Reporter)

Comment 4

12 years ago
I have removed all of the Windows fonts (Arial, etc) and the offendig pages (which indeed included Google searches) now render properly with Mac OS X fonts. The problem, though, persits on beta: the size of characters is not properly guessed by Camino.

Comment 5

12 years ago
Definitely a dupe then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 288047

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.