popups with -moz-border-radius will have black background outside radius

RESOLVED DUPLICATE of bug 318914

Status

()

RESOLVED DUPLICATE of bug 318914
12 years ago
12 years ago

People

(Reporter: ihoss.com, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

A popup or menu with a -moz-border-radius will not have a transparent background colour outside the border, but a black fill. 

Reproducible: Always

Steps to Reproduce:
1. Open userchrome.css
2. Enter
popup{
  -moz-border-radius: 10px;
}
3. Restart Firefox and rightclick to bring up the context menu.
Actual Results:  
The context menu will have a black background outside the rounded corners.

Expected Results:  
The context menu should have a transparent background outside the rounded corners.
(Reporter)

Comment 1

12 years ago
Edit: This is the userChrome content:
menupopup,
popup {
  -moz-border-radius: 10px !important;
  padding: 10px 0px !important;
}
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 318914
You need to log in before you can comment on or make changes to this bug.