Closed Bug 370910 Opened 13 years ago Closed 13 years ago

Update suiterunner Classic and Modern theme icon/preview

Categories

(SeaMonkey :: UI Design, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0a1

People

(Reporter: kairo, Assigned: kairo)

References

Details

Attachments

(4 files)

We should do better-looking icons and previews for our prepackaged themes on suiterunner.
This is a zip of the new set of icons and previews I have generated, to be unpacked in suite/themes/
Attachment #255699 - Flags: superreview?(neil)
Attachment #255699 - Flags: review?(neil)
This additional patch makes Classic be called "SeaMonkey default theme" in the UI, as this description matches its intent much better ("Classic" should probably stay connected with the classic Netscape-style icons).

Note that this value is cached in the profile's extensions.rdf, so you might not see it if you don't recreate your suiterunner profile.
Attachment #255700 - Flags: superreview?(neil)
Attachment #255700 - Flags: review?(neil)
And here's a screenshot how this looks in the Add-Ons/themes Window (default theme selected)
Another screenshot of the Add-Ons/themes Window, with Modern selected
Attachment #255702 - Attachment is patch: false
Attachment #255702 - Attachment mime type: text/plain → image/png
(In reply to comment #2)
> Created an attachment (id=255700) [details]
> call Classic "SeaMonkey default theme" in UI

I think this should be "SeaMonkey Default Theme" as its a title, therefore it looks better with the capitals.
Summary: Update suitrunner Classic and Modern theme icon/preview → Update suiterunner Classic and Modern theme icon/preview
Comment on attachment 255699 [details]
new icons/previews v1, to be unpacked in suite/themes

I don't like the wording "default theme" in the image. Just SeaMonkey and the icon set would seem to suffice.
Attachment #255699 - Flags: superreview?(neil)
Attachment #255699 - Flags: superreview+
Attachment #255699 - Flags: review?(neil)
Attachment #255699 - Flags: review+
Comment on attachment 255700 [details] [diff] [review]
call Classic "SeaMonkey default theme" in UI

I agree with Default Theme.
Attachment #255700 - Flags: superreview?(neil)
Attachment #255700 - Flags: superreview+
Attachment #255700 - Flags: review?(neil)
Attachment #255700 - Flags: review+
Checked in (with "Default Theme" and a modified preview that only has "SeaMonkey" and the icons)
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Duplicate of this bug: 353294
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.