Loading big image crashes gecko

RESOLVED DUPLICATE of bug 210931

Status

()

Core
General
--
critical
RESOLVED DUPLICATE of bug 210931
11 years ago
11 years ago

People

(Reporter: Paul Wellner Bou, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.1) Gecko/20061208 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.1) Gecko/20061208 Firefox/2.0.0.1

Trying to open this page with the big image or trying to load only the big images causes gecko to crash. I tried it with epiphany, too, so I am quite sure that this is a Gecko (or X) problem. I am using Debian unstable, Xorg 7.1.0-11.

I am not sure which component to select for this bug. Images? GFX? Xlib? So I choose "General".

I get this error in the console:

The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 38515 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


Reproducible: Always

Steps to Reproduce:
1.Load this url: http://www.flickr.com/photo_zoom.gne?id=373682626&size=o Or go directly to the big image: http://farm1.static.flickr.com/139/373682626_6f88a0f3b0_o_d.jpg
2.The browser crashes
Actual Results:  
It crashes. Output:
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 38515 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


Expected Results:  
Not to crash, display the image.

Comment 1

11 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20061022 Minefield/3.0a1

See 

Bug 321486 "Crash if I open some websites" (there are others)
Bug 210931 "Mozilla should reset the X error handler to trap overallocation failures in gtk/gtk2 libraries [@ nsImageGTK::DrawCompositeTile ]"

It probably makes sense to Dup these large image Bugs to Bug 210931.

Comment 2

11 years ago
I agree with Ben; this is a dupe. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 210931
You need to log in before you can comment on or make changes to this bug.