Closed Bug 371084 Opened 13 years ago Closed 2 years ago

add java applets to testing

Categories

(Testing :: General, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: ray, Assigned: ray)

Details

Attachments

(2 files)

28.81 KB, application/octet-stream
Details
78.75 KB, application/octet-stream
Details
We do not have an automated way to test these yet, but we do have a list of applets that would be worth using in testing.

See: http://wiki.mozilla.org/MozillaQualityAssurance:Test_JavaApplets

This page has a list of URLs with applets we could use.
Attached file paint applet
http://anfyteam.com/anj/anfypaint/anfypaint.html
Assignee: nobody → ray
Status: NEW → ASSIGNED
Here's a list of the Java applet sites I routinely use for testing (in no
particular order).  They're mostly ones that have given me some kind of
trouble in the past.  Some of these sites are very well known (like
weather.gov and www.java.com).  I'll include them anyway for the sake of
completeness.  Many of these use LiveConnect to some degree, but the last two
specifically target LiveConnect, and the liveconnecttest one is the best
LiveConnect test suite I've ever seen.

http://www.java.com/en/download/help/testvm.xml
http://gemal.dk/browserspy/java.html
http://www.weather.gov/radar_tab.php (click on map and choose "loop")
http://www.intellicast.com/IcastPage/LoadPage.aspx?loc=usa&seg=LocalWeather&prodgrp=RadarImagery&product=JavaLoop&prodnav=none
http://www.jigzone.com/
http://www.lohn1.de/lobn.htm
http://jmol.sourceforge.net/demo/
http://saintmarys.edu/~pbays/Stereochemistry.html
http://securitywizardry.com/radar.htm
http://brittnysseafood.com/
http://www.map24.com/
http://www.citeulike.org/nocrawl/touchgraph_applet.adp?article_id=47
http://www.sferyx.com/htmleditorapplet/demo/htmleditordemo.php
http://navsurf.com/applets/colorpicker/
http://www.kaon.com/software/swflash.html
http://www.xrce.xerox.com/competencies/content-analysis/arabic/input/keyboard_input.html
http://poslfit.homeip.net/test/liveconnecttest.html (best I've ever seen)
http://information.overlaid.com/stable/weasel/installation/java.html (also LiveConnect)

And here are three more, all bank sites.  The first one uses a Java applet
with a visible UI.  The second two use applets without any visible UI, which
get their input (via LiveConnect) from JavaScript objects.

https://internet-banking.dbs.com.sg/IB/Welcome
https://www.ocbc.com/internet-banking/
https://uniservices3.uobgroup.com/CLO/Pub_ControllerServlet?cmd=customerlogin&action=clologin
Here's another site I sometimes test with, that makes very sophisticated use
of a Java applet.  To see the applet you need to do a search and click on the
"Map View" tab.

http://grokker.com/
This is great.

We will have to mark which of these would be relocatable. In other words, with some of these, we would be able to download the files and use them for testing locally. For some of these, such as the banking sites, we will not want to try this.

But it is good to know about all of these. Thanx.
You're quite welcome.  I'm glad Mozilla.org is trying to formalize its
Java applet testing.

I understand why it isn't feasible to relocate the banking sites.  But
you'll need to be careful not to test them too much at any one time --
otherwise the sites' owners might think they're under attack :-)
I test with the applet on this page (uses "object" tag)

http://ww2.cs.fsu.edu/~steele/XHTML/appletObject.html


Here is a simple java applet test page that an be easily copied and automated:
http://www.jigzone.com/xmockup/bugs/resizeTestFF.php

It will test that the replaced element is renderd in the correct position and that it is re-sized correctly when it's containing html is re-sized by javascript.
Everything left in Core:Testing is going to Testing:General. Filter on CleanOutCoreTesting to ignore.
Component: Testing → General
Product: Core → Testing
QA Contact: testing → general
> As best I can tell, all but one of the bank sites from comment #3
> have stopped using Java.  But sometimes banking services aren't
> available on weekends, so I really need to recheck on Monday.  I'll
> do that and post another comment.

I've confirmed this.  Only the following (of the three bank sites)
still uses Java:

https://uniservices3.uobgroup.com/CLO/Pub_ControllerServlet?cmd=customerlogin&action=clologin

Also, since comment #10 the http://www.prophet.net/ site has been shut
down, so the following link no longer works:

http://www.prophet.net/analyze/javacharts.jsp?symbol=AAPL

The http://www.sferyx.com/ pages have similar functionality.  And
here's another stock charts site that's still available	(one that uses
Java applets):

http://www.boursorama.com/graphiques/graphique_histo.phtml?symbole=INTC&applet=1
There may be resources in the OpenJDK project that can be used for this effort.
> http://www.weather.gov/radar_tab.php (click on map and choose "loop")

This page no longer uses Java :-(

But there's at least one NOAA page that still uses Java to dynamically loop weather maps:

http://www.prh.noaa.gov/hnl/pages/sat_Hawaiiir.php
The HTML <applet> element and related java functionality was removed from Gecko in Bug 1279218. Marking related bugs as invalid.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.