Closed Bug 371249 Opened 13 years ago Closed 12 years ago

inline-block elements ignore text-decoration

Categories

(Core :: Layout: Block and Inline, defect, P3)

x86
Windows XP
defect

Tracking

()

VERIFIED FIXED
mozilla1.9beta2

People

(Reporter: moz, Assigned: dbaron)

References

Details

(Keywords: regression, testcase, Whiteboard: [dbaron-1.9:Rf][patch])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070220 Minefield/3.0a3pre
Build Identifier: 

No text-decoration is drawn when display: inline-block is set.

Reproducible: Always

Steps to Reproduce:
See testcase
Attached file testcase
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Looks like Ria may have already found the regression range, but I'll go ahead and say that I confirmed this regressed between 2007-01-27-04 and 2007-01-28 on Windows. http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-01-27+03&maxdate=2007-01-28+05&cvsroot=%2Fcvsroot
Keywords: regression
(In reply to comment #2)
> Looks like Ria may have already found the regression range, but I'll go ahead
> and say that I confirmed this regressed between 2007-01-27-04 and 2007-01-28 on
> Windows.

In fact, this isn't a regression, we had no inline-block before.
Support for "inline-block" display property was checked in 2007-01-27 10:36 by dbaron (bug 9458).

Flags: blocking1.9?
(In reply to comment #3)
> In fact, this isn't a regression, we had no inline-block before.

Otherwise, regression keyword is ok. This bug breaks
http://elektronotdienst.netfirms.com/
Links not underlined on current trunk, working with FF2.

Flags: blocking1.9? → blocking1.9+
Assignee: nobody → dbaron
Whiteboard: [dbaron-1.9:Rf]
Attached patch patchSplinter Review
Same bug was present for inline-block and table-caption.  I need to make sure there are bugs on file for the reftest failures for the tests that I wrote.
Attachment #286619 - Flags: superreview?(roc)
Attachment #286619 - Flags: review?(roc)
Whiteboard: [dbaron-1.9:Rf] → [dbaron-1.9:Rf][patch]
Attachment #286619 - Flags: superreview?(roc)
Attachment #286619 - Flags: superreview+
Attachment #286619 - Flags: review?(roc)
Attachment #286619 - Flags: review+
Comment on attachment 286619 [details] [diff] [review]
patch

Want to request approval1.9, but it doesn't appear to be requestable.
Attachment #286619 - Flags: approval1.9?
Comment on attachment 286619 [details] [diff] [review]
patch

a=release drivers
Attachment #286619 - Flags: approval1.9? → approval1.9+
Fix checked in to trunk.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M10
Filed bug 403524 on the quirks mode testcase -- we should fix it by merging quirks and standards mode text-decoration.
Filed bug 403526 on the propagation to floats in standards mode.
Flags: in-testsuite+
verified fixed using  Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007113005 Minefield/3.0b2pre. I verified using the testcase and by visiting the site in comment 4.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.