Minefield start-up Dock dance on Mac causes crash

RESOLVED DUPLICATE of bug 349463

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 349463
11 years ago
11 years ago

People

(Reporter: Ray Kiddy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

18.26 KB, application/octet-stream
Details
(Reporter)

Description

11 years ago
Created attachment 256094 [details]
crash log

I downloaded the nightly build of 3.0a3pre for the Mac. I am running on my intel Mac wit 10.4.8.

After I first launched the app, I told the Dock to keep the icon. I quit Minefield.

I rebooted. I re-launched Minefield.

The Dock icon bounced. A new Minefield Dock icon appeared. They both had the "running" indicator under the Dock. Then the instance from the first icon crashed. Now I only have one Minefield running. But it is the wrong Dock icon? Weird.

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x0000000c

Thread 0 Crashed:
0   libxpcom_core.dylib         0x00dac32c PL_DHashTableOperate + 24
1   libxpcom_core.dylib         0x00db59cf AtomImpl::~AtomImpl [in-charge]() + 61
2   libxpcom_core.dylib         0x00db5a55 AtomImpl::~AtomImpl [in-charge]() + 195
3   libxpcom_core.dylib         0x00dacb18 nsCOMPtr_base::~nsCOMPtr_base [not-in-charge]() + 20
4   org.mozilla.firefox         0x003cebe7 nsCSSSelector::Reset() + 73
5   org.mozilla.firefox         0x003cec84 nsCSSSelector::~nsCSSSelector [in-charge]() + 20
6   org.mozilla.firefox         0x003cecdd nsCSSSelectorList::~nsCSSSelectorList [in-charge]() + 25
7   org.mozilla.firefox         0x003ced49 CSSStyleRuleImpl::~CSSStyleRuleImpl [in-charge deleting]() + 39
8   org.mozilla.firefox         0x00581103 nsCSSRule::nsCSSRule[not-in-charge](nsCSSRule const&) + 95
9   libxpcom_core.dylib         0x00dacf05 nsCOMArray_base::~nsCOMArray_base [not-in-charge]() + 49
10  org.mozilla.firefox         0x0016a5ae nsCSSStyleSheetInner::~nsCSSStyleSheetInner [in-charge deleting]() + 84
11  org.mozilla.firefox         0x00169cca nsCSSStyleSheet::~nsCSSStyleSheet [in-charge deleting]() + 216
12  org.mozilla.firefox         0x00168f4a nsMediaList::~nsMediaList [in-charge]() + 144
13  libxpcom_core.dylib         0x00dacb18 nsCOMPtr_base::~nsCOMPtr_base [not-in-charge]() + 20
14  org.mozilla.firefox         0x0012e899 CSSParserImpl::~CSSParserImpl [in-charge deleting]() + 69
15  org.mozilla.firefox         0x0012e513 CSSParserImpl::ParsePseudoClassWithIdentArg(nsCSSSelector&, nsIAtom*, unsigned&) + 331
16  libxpcom_core.dylib         0x00dacf05 nsCOMArray_base::~nsCOMArray_base [not-in-charge]() + 49
17  org.mozilla.firefox         0x00129c8d CSSLoaderImpl::Shutdown() + 25
18  org.mozilla.firefox         0x001c08e9 nsLayoutStatics::Shutdown() + 49
19  org.mozilla.firefox         0x003e6f12 nsGlobalWindow::~nsGlobalWindow [not-in-charge]() + 526
20  org.mozilla.firefox         0x007dad06 nsGlobalChromeWindow::~nsGlobalChromeWindow [in-charge deleting]() + 122
21  org.mozilla.firefox         0x003df401 nsGlobalWindow::GetGlobalObjectOwner() + 703
22  org.mozilla.firefox         0x00343820 XPCJSRuntime::GCCallback(JSContext*, JSGCStatus) + 222
23  org.mozilla.firefox         0x00475bf4 nsJSContext::LoadEnd() + 124
24  libmozjs.dylib              0x00d337ab js_GC + 3494
25  libmozjs.dylib              0x00d130e7 js_DestroyContext + 488
26  libmozjs.dylib              0x00d0664e JS_DestroyContext + 25
27  org.mozilla.firefox         0x000b1172 XPCJSContextStack::~XPCJSContextStack [in-charge deleting]() + 42
28  org.mozilla.firefox         0x000b1421 XPCPerThreadData::Cleanup() + 121
29  org.mozilla.firefox         0x000b1a73 XPCPerThreadData::~XPCPerThreadData [in-charge]() + 19
30  org.mozilla.firefox         0x000b1b08 XPCPerThreadData::~XPCPerThreadData [in-charge]() + 168
31  libnspr4.dylib              0x00bbb47b _PR_DestroyThreadPrivate + 105
32  libnspr4.dylib              0x00bce6f0 PR_Yield + 99
33  libnspr4.dylib              0x00bce9ea _PR_InitThreads + 367
34  dyld                        0x8fe0e32d ImageLoaderMachO::doTermination(ImageLoader::LinkContext const&) + 85
35  dyld                        0x8fe030ec dyld::runTerminators() + 114
36  libSystem.B.dylib           0x9000ff5c __cxa_finalize + 237
37  libSystem.B.dylib           0x9000fe58 exit + 24
38  org.mozilla.firefox         0x00003166 start + 278
39  org.mozilla.firefox         0x00003079 start + 41
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 349463
You need to log in before you can comment on or make changes to this bug.