Seamonkey 1.0.8 and 1.1.1 won't build on Solaris 8 with GTK1

RESOLVED DUPLICATE of bug 234035

Status

SeaMonkey
Build Config
--
critical
RESOLVED DUPLICATE of bug 234035
11 years ago
11 years ago

People

(Reporter: Jeff Wieland, Unassigned)

Tracking

1.8 Branch
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.1.2) Gecko/20070221 SeaMonkey/1.1.1
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.1.2) Gecko/20070221 SeaMonkey/1.1.1

Seamonkey 1.0.7 and 1.1 build fine with GTK1 under Solaris 8.

Reproducible: Always

Steps to Reproduce:
1. Just do my normal build process.
2.
3.
Actual Results:  
/opt/SUNWspro/bin/CC -xtarget=ultra -xO4 -xbuiltin=%all -xlibmil -xarch=v8plusa -xdepend=yes -o nsFreeType.o -c  -DMOZILLA_INTERNAL_API -DOSTYPE=\"SunOS5\" -DOSARCH=\"SunOS\" -DBUILD_ID=2007022110 -I../.. -I../../../dist/include/xpcom -I../../../dist/include/string -I../../../dist/include/pref -I../../../dist/include/uconv -I../../../dist/include/unicharutil -I../../../dist/include/gfx -I../../../dist/include -I../../../dist/include/nspr    -I../../../dist/sdk/include -I/usr/sfw/include/freetype2 -I/usr/sfw/include -I/usr/openwin/include     -I/usr/openwin/include -xtarget=ultra -xO4 -xbuiltin=%all -xlibmil -xarch=v8plusa -xdepend=yes -xbuiltin=%all -features=tmplife -mt  -DNDEBUG -DTRIMMED -xtarget=ultra -xO4 -xbuiltin=%all -xlibmil -xarch=v8plusa -xdepend=yes  -I/usr/openwin/include -DMOZILLA_CLIENT -D_MOZILLA_CONFIG_H_ -DMOZILLA_VERSION=\"1.8.0.10\" -DMOZILLA_VERSION_U=1.8.0.10 -DSOLARIS=1 -DNSCAP_DISABLE_DEBUG_PTR_TYPES=1 -DD_INO=d_ino -DSTDC_HEADERS=1 -DHAVE_ST_BLKSIZE=1 -DHAVE_SIGINFO_T=1 -DHAVE_INT16_T=1 -DHAVE_INT32_T=1 -DHAVE_INT64_T=1 -DHAVE_UINT=1 -DHAVE_UINT_T=1 -DHAVE_UINT16_T=1 -DHAVE_DIRENT_H=1 -DHAVE_SYS_BYTEORDER_H=1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1 -DHAVE_NL_TYPES_H=1 -DHAVE_MALLOC_H=1 -DHAVE_X11_XKBLIB_H=1 -DHAVE_SYS_STATVFS_H=1 -DHAVE_SYS_STATFS_H=1 -DHAVE_LIBM=1 -DHAVE_LIBDL=1 -DHAVE_LIBSOCKET=1 -DFUNCPROTO=15 -DHAVE_XSHM=1 -D_REENTRANT=1 -DHAVE_RANDOM=1 -DHAVE_STRERROR=1 -DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1 -DHAVE_MEMMOVE=1 -DHAVE_RINT=1 -DHAVE_STAT64=1 -DHAVE_LSTAT64=1 -DHAVE_FLOCKFILE=1 -DHAVE_LOCALTIME_R=1 -DHAVE_STRTOK_R=1 -DHAVE_LANGINFO_CODESET=1 -DVA_COPY=va_copy -DHAVE_VA_COPY=1 -DHAVE_I18N_LC_MESSAGES=1 -DMOZ_DEFAULT_TOOLKIT=\"gtk\" -DMOZ_WIDGET_GTK=1 -DMOZ_ENABLE_XREMOTE=1 -DMOZ_X11=1 -DMOZ_SUITE=1 -DMOZ_BUILD_APP=suite -DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DMOZ_ENABLE_COREXFONTS=1 -DMOZ_EXTRA_X11CONVERTERS=1 -DOJI=1 -DIBMBIDI=1 -DMOZ_VIEW_SOURCE=1 -DMOZ_XPINSTALL=1 -DMOZ_JSLOADER=1 -DMOZ_XTF=1 -DMOZ_MATHML=1 -DMOZ_UPDATE_CHANNEL=default -DMOZ_STORAGE=1 -DNS_DISABLE_LOGGING=1 -DMOZ_USER_DIR=\".mozilla\" -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1 -DMOZ_DLL_SUFFIX=\".so\" -DXP_UNIX=1 -DUNIX_ASYNC_DNS=1 -DJS_THREADSAFE=1 -DNS_PRINT_PREVIEW=1 -DNS_PRINTING=1 -DMOZILLA_LOCALE_VERSION=\"1.8\" -DMOZILLA_REGION_VERSION=\"1.8\" -DMOZILLA_SKIN_VERSION=\"1.8\"  nsFreeType.cpp
"../../../dist/include/gfx/nsIFreeType2.h", line 53: Error: FTC_Image_Cache is not defined.
"../../../dist/include/gfx/nsIFreeType2.h", line 53: Error: A member cannot be initialized except in a constructor.
"../../../dist/include/gfx/nsIFreeType2.h", line 56: Error: Use ";" to terminate declarations.
"../../../dist/include/gfx/nsIFreeType2.h", line 92: Error: FTC_Image_Cache is not defined.
"../../../dist/include/gfx/nsIFreeType2.h", line 92: Error: A member cannot be initialized except in a constructor.
"../../../dist/include/gfx/nsIFreeType2.h", line 95: Error: Use ";" to terminate declarations.
"../../../dist/include/gfx/nsIFreeType2.h", line 104: Error: FTC_Image_Cache is not defined.
"../../../dist/include/gfx/nsIFreeType2.h", line 104: Error: A member cannot be initialized except in a constructor.
"../../../dist/include/gfx/nsIFreeType2.h", line 107: Error: Use ";" to terminate declarations.
"nsFreeType.h", line 123: Error: FTC_Image_Cache is not defined.
"nsFreeType.h", line 129: Error: FTC_Image_Cache is not defined.
"nsFreeType.h", line 161: Error: FTC_Image_Cache is not defined.
"nsFreeType.h", line 161: Error: FTC_Image_Cache is not defined.
"nsFreeType.h", line 161: Error: FTC_Image_Cache is not defined.
"nsFreeType.h", line 232: Error: Type name expected instead of "FTC_Image_Cache".
"nsFreeType.cpp", line 291: Error: FTC_Image_Cache is not defined.
"nsFreeType.cpp", line 295: Error: cache is not defined.
"nsFreeType.cpp", line 295: Error: desc is not defined.
"nsFreeType.cpp", line 295: Error: glyphID is not defined.
"nsFreeType.cpp", line 295: Error: glyph is not defined.
"nsFreeType.cpp", line 295: Error: Too many arguments in call to "int(*)()".
"nsFreeType.cpp", line 329: Error: FTC_Image_Cache is not defined.
"nsFreeType.cpp", line 332: Error: cache is not defined.
"nsFreeType.cpp", line 332: Error: Too many arguments in call to "int(*)(FTC_ManagerRec_*)".
"nsFreeType.cpp", line 398: Error: FTC_Image_Cache is not defined.
Compilation aborted, too many Error messages.
gnumake[5]: *** [nsFreeType.o] Error 1
gnumake[5]: Leaving directory `/home/ct344919-a/b/src/seamonkey/seamonkey-1.0.8/mozilla/gfx/src/freetype'
gnumake[4]: *** [libs] Error 2
gnumake[4]: Leaving directory `/home/ct344919-a/b/src/seamonkey/seamonkey-1.0.8/mozilla/gfx/src'
gnumake[3]: *** [libs] Error 2
gnumake[3]: Leaving directory `/home/ct344919-a/b/src/seamonkey/seamonkey-1.0.8/mozilla/gfx'
gnumake[2]: *** [tier_9] Error 2
gnumake[2]: Leaving directory `/home/ct344919-a/b/src/seamonkey/seamonkey-1.0.8/mozilla'
gnumake[1]: *** [default] Error 2
gnumake[1]: Leaving directory `/home/ct344919-a/b/src/seamonkey/seamonkey-1.0.8/mozilla'
gnumake: *** [build] Error 2


Expected Results:  
It should compile.

My mozconfig file looks like:

mk_add_options MOZ_CO_PROJECT=suite
mk_add_options BUILD_OFFICIAL=1
mk_add_options MOZILLA_OFFICIAL=1
ac_add_options --enable-application=suite
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --enable-optimize="-xtarget=ultra -xO4 -xbuiltin=%all -xlibmil -xarch=v8plusa -xdepend=yes"
ac_add_options --prefix=/opt/mozilla
ac_add_options --x-includes=/usr/openwin/include
ac_add_options --x-libraries=/usr/openwin/lib
ac_add_options --enable-jsd
ac_add_options --enable-toolkit-gtk
ac_add_options --enable-default-toolkit=gtk
ac_add_options --enable-freetype2
ac_add_options --disable-xft
ac_add_options --with-xprint
ac_add_options --enable-xprint
ac_add_options --enable-xinerama
ac_add_options --enable-extensions
ac_add_options --enable-mathml
ac_add_options --disable-strip
ac_add_options --enable-x11-shm
ac_add_options --enable-crypto
ac_add_options --disable-gcc-pipe
ac_add_options --disable-dtd-debug
ac_add_options --enable-static
ac_add_options --disable-shared
ac_add_options --enable-js-ultrasparc
ac_add_options --disable-calendar
ac_add_options --enable-ldap
ac_add_options --disable-pedantic
ac_add_options --enable-xterm-updates
ac_add_options --disable-logging
ac_add_options --disable-accessibility
ac_add_options --disable-ctl
ac_add_options --disable-auto-deps

Comment 1

11 years ago
There are patches in bug 234035 that might help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.8 Branch
Duplicate of bug: 234035
You need to log in before you can comment on or make changes to this bug.