Closed Bug 371367 Opened 13 years ago Closed 13 years ago

Entered title is not shown in print output, only 'about:blank' is shown

Categories

(Calendar :: Printing, defect)

x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Sunbird 0.5

People

(Reporter: ssitter, Assigned: ssitter)

Details

(Keywords: regression)

Attachments

(1 file)

Using Thunderbird/2.0pre (20070222) + Lightning/0.4a1 (2007022303)

Steps to Reproduce:
1. Check File -> Page Setup -> Header & Footer that Title is selected
2. Switch to Calendar view
3. Select Print calendar command
4. Enter title in Print Preview and select any print format and range
5. Print and check output

Actual Results:
Print output doesn't show the title that is entered in Print Preview dialog. Instead 'about:blank' is shown in print output.

Expected Results:
The title entered in Print Preview dialog should be shown in print output.

Regression:
Works in Sunbird/0.4a1 (2007-02-13-05)
Fails in Sunbird/0.4a1 (2007-02-13-08)
In addition to innerHTML we also need to set the title so that the title will show up in print output. (This is also a regression from the 'use-no-temp-file' fix in Bug 351957)
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #259598 - Flags: first-review?(lilmatt)
Comment on attachment 259598 [details] [diff] [review]
rev0 - set title to the content iframe

r=lilmatt
Attachment #259598 - Flags: first-review?(lilmatt) → first-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4pre) Gecko/20070401 Calendar/0.5pre
Status: RESOLVED → VERIFIED
Reopen,
Sunbird still prints about:blank, top right corner

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5pre) Gecko/20070707 Calendar/0.7pre
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Whiteboard: [litmus testcase wanted]
(In reply to comment #5)
Damian, about:blank is the URL of the document and is expected to be about:blank because we don't have html file anymore.
See menu File -> Page Setup -> Header & Footer. By default configuration the Tile is shown in the top left. Setting back to FIXED.
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
Flags: in-litmus?
Whiteboard: [litmus testcase wanted]
Target Milestone: --- → Sunbird 0.5
You need to log in before you can comment on or make changes to this bug.