Bad accesskeys in "This Frame" context submenu

VERIFIED DUPLICATE of bug 251339

Status

()

Firefox
Keyboard Navigation
VERIFIED DUPLICATE of bug 251339
11 years ago
10 years ago

People

(Reporter: Aaron Andersen, Assigned: Aaron Andersen)

Tracking

(Blocks: 1 bug, {access, verifyme})

Trunk
access, verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

11 years ago
Context Menu > This Frame :

 /==========================\
 |Sho_w_ Only This Frame    |
 |Open Frame in New _W_indow|
 |Open Frame New _T_ab      |
 |--------------------------|
 |_R_eload Frame            |
 |--------------------------|
 |Bookmark This _F_rame...  |
 |Save _F_rame as...        |
 |--------------------------|
 |View Frame _S_ource       |
 |V_i_ew Frame Info         |
 \==========================/

Problems:

1. Two menuitems use 'W' as an accesskey ('Show Only This Frame' and 'Open Frame  in New Window').

2. Two menuitems use 'F' as an accesskey ('Bookmark This Frame...' and 'Save Frame As...')

3. 'View Frame Info' uses a lowercase 'i' as an accesskey.



My suggestions:

1. For consistency with the link context menu, 'Open Frame in New Window' should get the 'W'. 'Show Only This Frame' can use 'h' or 'o'.

2. For consistency with the main context menu, 'Bookmark This Frame' should use 'm', leaving the 'F' for 'Save Frame As...', consistent with 'Save Page As...' in the main context menu.

3. 'View Frame Info' can still use 'I', it just need to be the uppercase I in Info and not the lowercase i in View.


The menu would then look like this:

 /==========================\
 |S_h_ow Only This Frame    |
 |Open Frame in New _W_indow|
 |Open Frame New _T_ab      |
 |--------------------------|
 |_R_eload Frame            |
 |--------------------------|
 |Book_m_ark This Frame...  |
 |Save _F_rame as...        |
 |--------------------------|
 |View Frame _S_ource       |
 |View Frame _I_nfo         |
 \==========================/


A simple path to /source/browser/locales/en-US/chrome/browser/browser.dtd is forthcoming. Is this a big enough deal that it should be changed on any of the branches?

Comment 1

11 years ago
duplicate of bug 251339 (or vice versa)
Version: unspecified → Trunk

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: verifyme
Resolution: --- → DUPLICATE
Duplicate of bug: 251339

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.