British-english dictionary add-on misspells certain words

RESOLVED INVALID

Status

()

Firefox
General
--
enhancement
RESOLVED INVALID
12 years ago
9 years ago

People

(Reporter: godfrey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

English words that have an "s" instead of the US "z", such as realise, not realize, and loads more! appear as errors and BritishEnglish dictionary AddOn suggests the American spelling to correct them. 
Or, perhaps I have downloaded BritishEnglish dictionary dictionary AddOn and it does not work? 
There is no way I can see what AddOns are actually working or not working in FireFix, and I ought to be able to Enable and/or Disable any AddOns, oughtn't (?) I?
Godfreyadsl@BTInternet.com.
Godfrey James, Caterham, England.

Reproducible: Always

Steps to Reproduce:
1.Use spellcheck after downloading BritishEnglish dictionary AddOn.
2.Spellcheck english words with "s" instead of (American) "z".
3.See resultant duff error message? Or, find out how to tell what AddOns are actually running at the time, and loaded with FireFox?
Actual Results:  
3.See resultant duff error message? Or, find out how to tell what AddOns are actually running at the time, and loaded with FireFox?

Expected Results:  
No error in BritishEnglish dictionary / Spellchecker
ps, none of the language dictionaries / spell checkers seem to be able to cope with words from other languages, even though the other dictionaries appear to be loaded: why is there not an option to spellcheck against a group of dictionaries, this is really needed for European users who tend to use several languages quite often..unlike the USofA, the EU has loads and loads of different languages!

There is no workaround for this, it can be a real pain.
With the extension downloaded here https://addons.mozilla.org/firefox/3366/ I see no red lines under realise and sanitise.
Add-ons are displayed in the Add-ons manager (Tools -> Add-ons).
And you can switch dictionaries with the Dictionary Switcher: https://addons.mozilla.org/firefox/3414/
Duplicate of this bug: 379022

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.