data: Spaces stripped on URIs from location bar on hitting enter

VERIFIED FIXED

Status

()

Core
Networking
P3
normal
VERIFIED FIXED
18 years ago
15 years ago

People

(Reporter: Jesse Ruderman, Assigned: Judson Valeski)

Tracking

({testcase})

Trunk
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
To reproduce: type "data:,foo bar" in location bar and press enter

Expected result: displays "foo bar" in a fixed-width font
Actual result: location bar changed to "data:foobar" and "foobar" is displayed.

This is a regression and makes testing other bugs frustrating.

Comment 1

18 years ago
davidr8@home.com, thanks for the bug. If you have a second, could you possibly 
skim through the component descriptions at http://bugzilla.mozilla.org/
describecomponents.cgi?product=Browser? 

This most likely doesn't go in UI: DF, probably belongs in Networking --- it's 
URL resolution. (only mentioning it because you do so much killer Bugzilla wor, 
and figured you'd want to know.) Thanks!
Assignee: bdonohoe → gagan
Component: User Interface: Design Feedback → Networking
QA Contact: elig → tever

Comment 2

18 years ago
andreas?

Comment 3

18 years ago
It seems this has nothing to do with networking resolution, that part works as
expected, this must be something else before that, maybe nsDocShell or
nsWebShell, I will try to find out.

Comment 4

18 years ago
Wrong! This has to do with networking, but only with data URIs. The rest works
fine. I think the fix for bug 35439 is the reason. CCing Judson, who "fixed" it,
changing summary.
Summary: Spaces stripped from location bar on hitting enter → Spaces stripped on data URIs from location bar on hitting enter
(Assignee)

Comment 5

18 years ago
mine
Assignee: gagan → valeski
(Assignee)

Comment 6

18 years ago
I'm having trouble entering data urls into the url bar at all, but I just 
checked in a fix to over-zealously stripping whitespace.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
Jesse, could you verify this please? Thanks.
Keywords: verifyme
(Reporter)

Comment 8

18 years ago
Verif 2000092608 Win98.
Works for text/plain and text/html when typing into url bar or following a link.
Status: RESOLVED → VERIFIED
Keywords: verifyme

Updated

15 years ago
Keywords: testcase
Summary: Spaces stripped on data URIs from location bar on hitting enter → data: Spaces stripped on URIs from location bar on hitting enter
You need to log in before you can comment on or make changes to this bug.