Mis-ordering of includes

VERIFIED FIXED in M16

Status

SeaMonkey
Build Config
P3
blocker
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: Nate Eldredge, Assigned: cls)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
A compilation command in a build looks like:

c++ -o nsPluginHostImpl.o -c -fno-rtti -fno-exceptions -pedantic -Wno-long-long
-O -g -I/usr/local/lib/glib/include -I/usr/local/include
-I/usr/local/X11R6.4//include -DMOZILLA_CLIENT -include ../../../config-defs.h
-Wp,-MD,.deps/nsPluginHostImpl.pp -DOSTYPE=\"SunOS5\" -DOJI -D_IMPL_NS_PLUGIN 
-I../../../dist/include -I../../../include     -I/usr/local/X11R6.4//include  
-fPIC nsPluginHostImpl.cpp

Note the order of -I options.

This Solaris machine happens to have a /usr/local/include/gui.h, which is then
included instead of ../../../include/gui.h.  Since /usr/local/include/gui.h is
in fact a tkobjc file, the consequences are dispiriting. :)

So basically, mozilla should be careful to include *its* headers before the
system's.

My .mozconfig is

  mk_add_options MOZ_MAKE_FLAGS=-j3
  ac_add_options --enable-optimize

Latest CVS.
(Assignee)

Comment 1

19 years ago
Created attachment 8010 [details] [diff] [review]
Moves OS_CFLAGS to end of CFLAGS
(Assignee)

Comment 2

19 years ago
See if this patch fixes your problem.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 3

19 years ago
Yes, that fixed it.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 4

19 years ago
marking verified.
Status: RESOLVED → VERIFIED
Target Milestone: --- → M16
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.