Closed Bug 372129 Opened 15 years ago Closed 8 years ago

wiki.mozilla.org: Justification doesn't work in default "Cavendish" skin

Categories

(Websites :: wiki.mozilla.org, defect)

defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: tonymec, Unassigned)

References

()

Details

(Whiteboard: [cavendish])

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3pre) Gecko/20070227 BonEcho/2.0.0.3pre
Build Identifier: "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3pre) Gecko/20070227 BonEcho/2.0.0.3pre" - Build ID: 2007022704

The "Justify Paragraphs" checkbox in the "Misc" preferences has no effect if the default "Cavendish" skin is used. It does have an effect in some other skins such as "Cologne Blue".

Reproducible: Always

Steps to Reproduce:
1. Log in to wiki.mozilla.org
2. In the "Preferences" page, select "Misc" and make sure the "Justify paragraphs" checkbox is ticked. (If it isn't, tick it, then "Save".)
3. Browse to http://wiki.mozilla.org/Documentation:_Introduction?useskin=cavendish (or any other page with paragraphs of at least two lines).
Actual Results:  
No text justification

Expected Results:  
Text should be justified, as on http://wiki.mozilla.org/Documentation:_Introduction?useskin=cologneblue (with the same settings)
Assignee: mitchell → nobody
Component: Miscellaneous → *.mozilla.org
OS: Linux → All
Product: mozilla.org → Websites
QA Contact: miscellaneous → other-mozilla-org
Hardware: PC → All
Version: other → unspecified
Can you specify which part of the linked pages are different. I don't see justified text on the "Cologne"-style version either.
(In reply to comment #1)
> Can you specify which part of the linked pages are different. I don't see
> justified text on the "Cologne"-style version either.
> 

I do: all paragraphs (of more than one line ;-) ) are justified to the right margin of my browser window in the "Cologne Blue" skin but they are ragged-right in the "Cavendish" skin. Are you sure you set your preferences (click "Preferences" in the site sidebar, then "Misc") to justify paragraphs, as mentioned in step 2 of comment #0 ? If you had to change that pref, did you "Save" ? Are your cookies allowed for that site ? Or are you sure you logged in to the site as in step 1 ?
BTW, Steven, I'm not trying to insult your competence, just to check everything that might have gone wrong. One section with particular long paragraphs is http://wiki.mozilla.org/Documentation:_Introduction#Feature_list (there the difference between flush right vs. ragged right should be particularly obvious). The fact that Cologne Blue is my skin of choice may be relevant but I think it isn't.
Tony - thanks for the clarification - I hadn't read the bug report clearly and didn't have the setting changed.

I can see the bug clearly now. I'm not sure why that style working for some themes and not the Cavendish theme - it doesn't look like we're over-riding it anywhere. I'll keep digging. MediaWiki expert help is welcome.
(In reply to comment #4)
Could the fact that in "Cologne Blue" the text goes all the way to the right margin of the browser window, while in "Cavendish" there is a significant amount of white space at the right, be relevant? (I use a maximized browser window in a 1024x768 monitor.)
Component: other.mozilla.org → wiki.mozilla.org
QA Contact: other-mozilla-org → wiki-mozilla-org
Tony, still see this?
Flags: needinfo?(antoine.mechelynck)
(In reply to Wayne Mery (:wsmwk) from comment #6)
> Tony, still see this?

Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0 SeaMonkey/2.20a1 ID:20130421003001 c-c:1637ab8d5a01 m-c:0d50cb959c46

Yes I do. I haven't been able to test with a more recent version of SeaMonkey because of a buildbot hardware breakdown, but I suspect that the error would be in the wiki.mozilla.org CSS, not in the browser.
Flags: needinfo?(antoine.mechelynck)
Flags: needinfo?(tech)
As an update on this, I've been looking at all the css files which can affect the display and, so far, find nothing to explain the difference. It may well be in the wiki.m.o css but it is hiding very well if so.
Alison: "Cologne Blue" (my favourite skin) is an old-style MediaWiki skin which works about the same way on all wikis using MediaWiki software (except of course the very few ones which, like wikia.com, have high-handedly removed it). "Monobook" is another more or less ubiquitous skin which equally allows justification. "Cavendish" is more Mozilla-specific; maybe it lacks (or comments away) the rule(s) which would enable justification if selected by the current logged-in user?

When I'm logged-in to wiki.mozilla.org, but don't specify a ?useskin= attribute in the URL, I notice the following at lines 13 sqq of the page source:


<link rel="stylesheet" href="https://wiki.mozilla.org/load.php?debug=false&amp;lang=en&amp;modules=mediawiki.legacy.oldshared%2Cshared%2Cwikiprintable%7Cskins.cologneblue&amp;only=styles&amp;skin=cologneblue&amp;*" />
<link rel="stylesheet" href="/extensions/Bugzilla/web/jqueryui/1.8.14/themes/base/jquery-ui.css" />
<link rel="stylesheet" href="/extensions/Bugzilla/web/jqueryui/1.8.14/themes/smoothness/jquery-ui.css" />
<link rel="stylesheet" href="/extensions/Bugzilla/web/css/demo_page.css" />
<link rel="stylesheet" href="/extensions/Bugzilla/web/css/demo_table.css" />
<link rel="stylesheet" href="/extensions/Bugzilla/web/css/bugzilla.css" /><style>/* @noflip */#quickbar { position:absolute; left:4px }
/* @noflip */#topbar { margin-left: 148px }
/* @noflip */#article { margin-left:148px; margin-right: 4px; }
/* @noflip */body>#quickbar { position:fixed; left:4px; top:4px; overflow:auto; bottom:4px;}
/* @noflip */#footer { margin-left: 152px; }</style><meta name="ResourceLoaderDynamicStyles" content="" />
<link rel="stylesheet" href="https://wiki.mozilla.org/load.php?debug=false&amp;lang=en&amp;modules=site&amp;only=styles&amp;skin=cologneblue&amp;*" />
<style>a:lang(ar),a:lang(ckb),a:lang(fa),a:lang(kk-arab),a:lang(mzn),a:lang(ps),a:lang(ur){text-decoration:none}a.new,#quickbar a.new{color:#ba0000}#article,#bodyContent,#mw_content{text-align:justify}

/* cache key: wiki_mozilla_org:resourceloader:filter:minify-css:7:3910bc75f122720abf08750a53105360 */</style>


The first of these lines shows that Mediawiki is clever enough to get my preferred "Cologne Blue" skin from my permanent Preferences stored somewhere on the server (they are common to all clients I care to use).
Note the {text-align:justify} near the end of what I quoted? I guess the (php or whatever) software wouldn't have generated it if it hadn't been in my Preferences. It is also present in the ?useskin=cavendish page but (aha!) unlike the one which defaults to my CologneBlus skin, the Cavendish page lacks the <div id='article'> starting just above the top title of the page, which triggers justification until the corresponding </div>.
Flags: needinfo?(tech)
Given our limited resources, we're not fixing non-critical bugs on deprecated themes. Reopen with additional info if you feel this is a critical bug.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
Whiteboard: [cavendish]
You need to log in before you can comment on or make changes to this bug.