Closed Bug 372352 (test-plugin) Opened 15 years ago Closed 13 years ago

NPAPI test plugin

Categories

(Core :: Plug-ins, enhancement)

enhancement
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 386676

People

(Reporter: sayrer, Unassigned)

References

(Blocks 1 open bug)

Details

On IRC, bz points out that it might be nice to have a test harness plugin. test cases would require writing c/c++.
Severity: normal → enhancement
OS: Mac OS X → All
Hardware: PC → All
http://download.developer.beonex.com/mozilla/npruntime.tgz may be a good place to start here as it already shows how to script a plugin which significantly helps the communication between the test(s) and the plugin.
fwiw, the npruntime sample plugin is now checked in under modules/plugin/samples/npruntime
Alias: test-plugin
Blocks: 408898
Blocks: 386676
Blocks: 393845
Blocks: 422926
Blocks: 369788
Status: NEW → RESOLVED
Closed: 13 years ago
Component: Testing → Plug-ins
QA Contact: testing → plugins
Resolution: --- → DUPLICATE
Duplicate of bug: 386676
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.