Float on :before and :after pseudo tags is not working.

RESOLVED DUPLICATE of bug 238072

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 238072
11 years ago
11 years ago

People

(Reporter: Andras Nemeseri, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a3pre) Gecko/20070302 Minefield/3.0a3pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a3pre) Gecko/20070302 Minefield/3.0a3pre

If you float the :after element (display set to block), the next block level element should appear next to it, not under it.

See the example page for details. The example is rendered correctly in Opera 9.1 and Safari 2.0.4. The paragraph should be placed next to the :before pseudo tag.

Reproducible: Always

Steps to Reproduce:
1. create a block element (called "a")
2. create a :before pseudo element on "a" with display: block and float: left and with an image content and fix width and height
3. try to position a block element (called "b") in "a" next to the :before element with float: left
Actual Results:  
Element "b" displayed under the :before and the containing element "a".

Expected Results:  
Element "b" ahould displayed next to :before element of "a".

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 238072
You need to log in before you can comment on or make changes to this bug.