On discussion board, going to first new message fails if there are inline images above it.

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
12 years ago
11 years ago

People

(Reporter: bill_walker, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060911 Camino/1.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060911 Camino/1.0.3

On the referenced discussion board (and others), if I click the link to take me to the first new message and the thread has inline images in messages prior to the first new message, the resulting location is somewhere above (prior to) the first new message.  Sometime you can see it go to the correct message, and then it'll scroll backwards as the images are decoded, even though the images are offscreen.

Reproducible: Always

Steps to Reproduce:
1. You'll need an account on a discussion board that allows inline images.
2. Read messages in a thread that has images.
3. Come back later, after more posts have been added, and click the link to go to the first new message.
Actual Results:  
See "Details".

Expected Results:  
Display should stay at the first new message.  Images that are not on screen at that point should not affect the position of the scroll bar.

This happens in Safari, too, but not, I think, in Firefox.

Comment 1

12 years ago
This may be a peculiarity of the UBB software, or it may be a function of connection speed, or both. It may also be a bug in Gecko (it's extremely unlikely this is a bug solely in Camino since it describes a behaviour of the content area, not the user interface) that happens to be (by pure coincidence) present in WebKit too, but that's pretty unlikely.

My gut feeling, especially since I've seen similar problems that are clearly BBS-related on phpBB forums, is that this is a bug in the UBB code, possibly combined with a slower connection speed.

Try something for me. Insert this in step 3 and see what you get.

3. Come back later, after more posts have been added, and Command-click the link to go to the thread so it opens in a new tab.
4. Wait for the new tab to load fully.
5. Click the link to go to the first new message.

I'll bet that works fine.

cl

Comment 2

12 years ago
The images don't have any dimensions specified in the html code. On first load of a page (un-cached), Gecko doesn't really now how deep the targeted link is on the page (how many pixels it has to scroll down), and takes a wild guess based on the text content. Once the images load, the page changes size, and the targeted post can be many windows deeper.
Slower connections speeds and very busy servers make it appear more frequently.

I _think_ there is a dupe somehere.

n.b. That problem used to be much worse...
(Reporter)

Comment 3

12 years ago
(In reply to comment #1)
 
> Try something for me. Insert this in step 3 and see what you get.
> 
> 3. Come back later, after more posts have been added, and Command-click the
> link to go to the thread so it opens in a new tab.
> 4. Wait for the new tab to load fully.
> 5. Click the link to go to the first new message.
> 
> I'll bet that works fine.

Not exactly.  It just skips going to the unread message and immediately ends up somewhere in the middle of the pictures in the thread.

BTW, in the coincidence department, Safari didn't have this problem until just a few months ago.  I can't speak for Camino, as I just started using it (and I love the speed improvement.  Reminds of when Safari first came out).

Comment 4

11 years ago
Philippe, if you can find the dupe, please dupe this appropriately. In the absence of further details on what's going on here, I'm going to resolve this INCOMPLETE. If someone can provide a reliable, minimised testcase with an explanation of what's happening, please feel free to reopen this bug (and probably kick it to Core for further triage, since it's unlikely that anything behaviour this deep in Gecko is Camino-specific).

cl
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.