PDF files are not displayed directly in browser

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
12 years ago
11 years ago

People

(Reporter: maczilla, Unassigned)

Tracking

2.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; de; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; de; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

The Mac version of Mozilla Firefox is not able to display PDF files directly in the browser window due to the lack of an according plugin.

Reproducible: Always

Steps to Reproduce:
1. Surf to a Web page with a link to a PDF file;
2. Click on the lik to the PDF file.
Actual Results:  
Mozilla Firefox opens the download dialogue.

Expected Results:  
Mozilla Firefox should display the PDF file in the browser window (actually the default behaviour of the Windows version of Mozilla Firefox).

I assume that Mozilla Firefox on the Mac cannot display PDF files in the browser window due to the lack of a working Universal Binary PDF plugin. The plugin available at http://www.schubert-it.com/pluginpdf/ is working but PowerPC only. Other plugins working with Mozilla Firefox are obviously not available, neither from Adobe (even with Adobe Reader 8.0 installed) nor from Apple (Safari is able to display PDF files in the browser windows).
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0 Branch

Comment 1

12 years ago
This isn't a Mozilla bug - Mozilla isn't responsible for the plug-ins. If you want the same behaviour of Safari (native display of PDF), see bug 91559 and bug 344620.
(Reporter)

Comment 2

12 years ago
There is obviously a PDF plugin available on the Mac, the one used by Safari. In addition, Adobe Reader is installed on many Mac systems… Mozilla Firefox on the Mac should therefore be able to display PDF files in the browser window, like its Windows counterpart.

Comment 4

12 years ago
That document does not apply to Mac OS X. Adobe does not support a browser plugin on OS X.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 219973

Comment 5

12 years ago
The bug I duped to did not do a good job of explaining what is the problem so here is the issue.

Unfortunately Adobe does not make a Adobe Reader plugin that is compatible with Firefox for OS X. http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=333545

You can suggest that Adobe develop a plugin at http://www.adobe.com/cfusion/mmform/index.cfm?name=wishform
Resolution: DUPLICATE → INVALID
You need to log in before you can comment on or make changes to this bug.