Closed Bug 372859 Opened 14 years ago Closed 4 years ago

Universal binary creation fails on Mac when official branding is disabled.

Categories

(Firefox Build System :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: coop, Unassigned)

References

()

Details

I'm trying to create free software builds to fulfill licensing reqs for the 2.0.0.2 release (we should have been doing this all along, but I digress). The build itself seems to work fine, but then fails in unify:

Here's the build log tail:

rm -rf ../build/unifox/ppc/dist/universal/firefox/BonEcho.app
/builds/tinderbox/Fx-Mozilla1.8-FS/Darwin_8.7.0_Clobber/mozilla/build/macosx/universal/unify \
  ../build/unifox/ppc/dist/firefox/BonEcho.app \
  ../build/unifox/i386/dist/firefox/BonEcho.app \
  ../build/unifox/ppc/dist/universal/firefox/BonEcho.app
/builds/tinderbox/Fx-Mozilla1.8-FS/Darwin_8.7.0_Clobber/mozilla/build/macosx/universal/unify: warning: makeUniversalDirectory: only in ppc ../build/unifox/ppc/dist/firefox/BonEcho.app/Contents/MacOS:
  redo-prebinding.sh
/builds/tinderbox/Fx-Mozilla1.8-FS/Darwin_8.7.0_Clobber/mozilla/../build/unifox/dist/Firefox.app/Contents/MacOS/firefox-bin does not exist.
Error: binary not found: firefox-bin

I assume this is more MOZ_APP_DISPLAYNAME badness (or similar, as seen in e.g. bug 307299) in that it's looking for Firefox.app when it should be looking for BonEcho.app.
Looks like the error occurs at this point:
  http://lxr.mozilla.org/mozilla/source/tools/tinderbox/build-seamonkey-util.pl#1157

full_binary_name is defined at
http://lxr.mozilla.org/mozilla/source/tools/tinderbox/build-seamonkey-util.pl#889

and depends on $Settings::DistBin, defined in the code leading up to 
http://lxr.mozilla.org/mozilla/source/tools/tinderbox/build-seamonkey-util.pl#518

And $ProductName is set to BonEcho in the tinder-config.pl. So I don't see the cause of the problem. 
It's not failing in unify, that message is printed by tinderbox.  Where's the tinder-config for this bad boy?
Public CVS 
Branch: MOZILLA_1_8_BRANCH_release_free_software
 
/mozilla/tools/tinderbox-configs/firefox/macosx
As far as I can tell from the build log for the 2.0.0.2 attempt, $ProductName had already been set to BonEcho in the tinder-config, and yet it failed. There are a mixture of references to BonEcho.app and Firefox.app in 
  http://people.mozilla.org/~nthomas/mac-fs/FIREFOX_2_0_0_2_FS.log
though.

When I used the same machine and config (apart from Tag and tinderbox tree changes) for the 2.0.0.3 free software build then this error didn't occur.
  http://people.mozilla.org/~nthomas/mac-fs/FIREFOX_2_0_0_2_FS.log
It seems to me like $ProductName is not set to 'BonEcho', although it's set properly on MOZILLA_1_8_BRANCH_release_free_software.  Are you sure that's the config that the tinderbox was using?  There's no ">Tinderbox Config Info<" section  (the section that dumps "cvs stat" from the config dir) in Nick's build logs, so it's hard to tell from here what revision of that file was actually in use.
From the 2.0.0.2 log, the checkout of mozilla/ began at "Mar  5 11:59:10 2007", at which point revision 1.14.2.2 of the tinder-config.pl had been checked in (fixing ProductName).

grep says there are the following counts in the logs:

              Firefox.app      BonEcho.app
  2.0.0.2         3               1059
  2.0.0.3         0               1070

So, for reasons unknown to me, tinderbox has not quite picked up the change.
We no longer do universal builds (bug 1295375).
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.