getTextAtOffset returns bad text, start, end offsets for list items

RESOLVED FIXED

Status

()

Core
Disability Access APIs
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: parente, Assigned: Aaron Leventhal)

Tracking

(Blocks: 1 bug, {access, regression})

Trunk
x86
Linux
access, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a3pre) Gecko/20070307 Minefield/3.0a3pre

Note: This was not a bug prior to the 20070307 build. It worked fine yesterday.

1) See attached HTML page.
2) Use AT-SPI's getTextAtOffset on the first list item. Return value is empty string, start offset = 0, end offset = 0.
3) Use AT-SPI's getText(0, -1). Return value is '<bullet> <embed>' (where <embed> represents the link).

getTextAtOffset should be returning the same thing as getText in this case since all of the text fits on one visible line.
(Assignee)

Updated

11 years ago
Blocks: 368895
(Assignee)

Updated

11 years ago
Keywords: access
(Assignee)

Updated

11 years ago
Keywords: regression
Summary: getTextAtOffset returns bad text, start, end offsets → getTextAtOffset returns bad text, start, end offsets for list items
(Reporter)

Comment 1

11 years ago
Created attachment 257738 [details]
test case
(Reporter)

Comment 2

11 years ago
Problem still exists in 2007-03-12 build after fix to caret events.
(Assignee)

Comment 3

11 years ago
Created attachment 258380 [details] [diff] [review]
Temporary workaround

Getting list item bullets to work properly with out hypertext implementation will be hard. But, this should be okay for now.

Surkov, will you approve a temporary fix like this? It basically puts us back where we were before, ignoring error conditions when PeekOffset() failed when going backwards starting at the bullet frame.
Attachment #258380 - Flags: review?(surkov.alexander)
(Reporter)

Updated

11 years ago
Attachment #258380 - Flags: review?(surkov.alexander) → review+
(Assignee)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 4

11 years ago
Aaron, can you file a bug for this where problem will be described and where will be presented possible approach to fix it?
You need to log in before you can comment on or make changes to this bug.