can't switch views: "gCalendarWindow has no properties"

VERIFIED FIXED

Status

Calendar
Calendar Views
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: myk, Unassigned)

Tracking

Sunbird 0.3.1
x86
All

Details

(Reporter)

Description

11 years ago
In this morning's nightly build (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3pre) Gecko/20070308 Calendar/0.5pre), I can't switch views, neither with the View menu commands nor with the toolbar buttons.  When I try, the following error message appears on the Error Console:

Error: gCalendarWindow has no properties
Source File: chrome://calendar/content/calendar.xul
Line: 1

Updated

11 years ago
Duplicate of this bug: 373188

Comment 2

11 years ago
There is also the Error: aDate is not defined
Source File: chrome://calendar/content/calendar-decorated-base.xml
Line: 104

I think that this is the primary error.  A fix has been checked in: to version 1.2.2.16 of mozilla/calendar/base/content/calendar-decorated-base.xml

If this checkin solves the issue in the next set of builds, we will mark this as fixed.
OS: Linux → All

Comment 3

11 years ago
I don't see the error in last hourly build Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.3pre) Gecko/20070308 Calendar/0.5pre ID:2007030807
(Reporter)

Comment 4

11 years ago
Works for me too in the latest nightly build for Linux.
FIXED by touch up checkin for bug 370836
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.