Crash at 20-30 min intervals xpcom_core.dll

RESOLVED DUPLICATE of bug 373219

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 373219
11 years ago
11 years ago

People

(Reporter: Jim Jeffery not reading bug-mail 1/2/11, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows Vista
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a3pre) Gecko/20070307 Minefield/3.0a3pre Firefox
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a3pre) Gecko/20070307 Minefield/3.0a3pre Firefox

Starting with today's nightly: 2007030804 every 20-30 minutes I get a crash in xpcom_core.dll

Talkbacks:
TB30044217Q
TB30043080Y
TB30042111H
TB30041104Y

Top three seem to point to canonicalize 



Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
No crash


System: Vista Home Premium 1.4Ghz AMD 1gig RAM, ATI 9500Pro video card.

Does not happen with the 2007030715 hourly build. Thus, it had to have regressed sometime after that and today's nightly build.
Also occurs in SafeMode and a new Profile with no extensions.

Updated

11 years ago
Keywords: crash, regression
Version: unspecified → Trunk
Three are:

Incident ID: 30042111
Stack Signature	canonicalize 8d26db28
Product ID	FirefoxTrunk
Build ID	2007030804
Trigger Time	2007-03-08 07:23:45.0
Platform	Win32
Operating System	Windows NT 6.0 build 6000
Module	xpcom_core.dll + (00030d2d)
URL visited	
User Comments	crash at accuweather gadget page
Since Last Crash	1979 sec
Total Uptime	3996 sec
Trigger Reason	Access violation
Source File, Line No.	e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\xpcom\base\nscyclecollector.cpp, line 630
Stack Trace 	
canonicalize  [mozilla/xpcom/base/nscyclecollector.cpp, line 630]
GraphWalker::NoteXPCOMChild  [mozilla/xpcom/base/nscyclecollector.cpp, line 641]
ControlTraverser  [mozilla/content/html/content/src/nshtmlformelement.cpp, line 570]
nsBaseHashtable<nsCStringHashKey,nsAutoPtr<nsPasswordManager::SignonHashEntry>,nsPasswordManager::SignonHashEntry *>::EnumerateRead  [mozilla/dist/include/xpcom/nsbasehashtable.h, line 188]
nsHTMLFormElement::cycleCollection::Traverse  [mozilla/content/html/content/src/nshtmlformelement.cpp, line 578]


One is

Incident ID: 30041104
Stack Signature	xpcom_core.dll + 0x30d2d (0x602d0d2d) 1855bbe0
Product ID	FirefoxTrunk
Build ID	2007030804
Trigger Time	2007-03-08 06:49:28.0
Platform	Win32
Operating System	Windows NT 6.0 build 6000
Module	xpcom_core.dll + (00030d2d)
URL visited	
User Comments	
Since Last Crash	2017 sec
Total Uptime	2017 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
xpcom_core.dll + 0x30d2d (0x602d0d2d)
xpcom_core.dll + 0x31994 (0x602d1994)
firefox.exe + 0x38c8d5 (0x0078c8d5)
firefox.exe + 0x491994 (0x00891994)
firefox.exe + 0x38d741 (0x0078d741)
Blocks: 368773
Component: General → XPCOM
Product: Firefox → Core
QA Contact: general → xpcom

Comment 4

11 years ago
Looks like this one:
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Component: XPCOM → General
Product: Core → Firefox
Resolution: --- → DUPLICATE
Duplicate of bug: 373219
You need to log in before you can comment on or make changes to this bug.