Authentication Required dialog does not indicate authentication type

RESOLVED DUPLICATE of bug 115500

Status

()

RESOLVED DUPLICATE of bug 115500
12 years ago
12 years ago

People

(Reporter: msg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506; .NET CLR 1.1.4322; InfoPath.2)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070301 Minefield/3.0a3pre

When performing HTTP authentication (basic, digest, ntlm, etc) a dialog box is displayed titled "Authentication Required".  This dialog box does not provide any indication of the authentication mechanism in use or even if the connection is encrypted using SSL (in 3.0pre the URL line is not updated with color, nor is the lock icon in place on a direct browse).

This prevents the end user from being able to make an informed decision regarding the entering of there username and password.

Reproducible: Always

Steps to Reproduce:
1. Directly browse to a website with SSL and requiring authentication (say basic)
2. Browse to site requiring Digest
3. Browse to site requiring NTLM
Actual Results:  
No indication is provided regarding the mechanism in use or it's "safety".

Expected Results:  
User should be informed about how there username/password will be transmitted.
Assignee: kengert → nobody
Component: Security: UI → Networking: HTTP
QA Contact: networking.http
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 115500
You need to log in before you can comment on or make changes to this bug.