Unable to set width attribute of legends in CSS

RESOLVED DUPLICATE of bug 292736

Status

()

Firefox
General
--
trivial
RESOLVED DUPLICATE of bug 292736
11 years ago
11 years ago

People

(Reporter: Mike Shelton, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

<legend style="width:200px">Test<legend>

In IE and Opera this is shown correctly, but Gecko isn't rendering it. Not a big deal, but it would be nice.

Reproducible: Always

Steps to Reproduce:
1.Create an XHTML document containing a fieldset
2.Put a legend inside of the fieldset
3.Style the width of the legend
Actual Results:  
The attribute is completely ignored.

Expected Results:  
If you specify a border with padding you should be able to see a block element at the specified width with the legend text inside.

Comment 1

11 years ago
Legend is an inline element.  Which changing it's display to block I would have thought would have allowed us to set its size.  But that's not the case due to bug 292736.  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 292736
You need to log in before you can comment on or make changes to this bug.