Closed Bug 373383 Opened 14 years ago Closed 13 years ago

Text dynamically pushed below a float by a long word fails to rewrap

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: jruderman, Assigned: dbaron)

References

(Blocks 1 open bug)

Details

(Keywords: regression, testcase)

Attachments

(2 files)

The testcase should not have a float-sized hole in text wrapping, and it should match the reference.

The testcase is based on reftests/bugs/361091-1-ref.html.
Attached file testcase
Attached file reference
Blocks: refdyn
Regressed between 2006-12-07 and 2006-12-08 -- looks like a reflow branch regression.

Which makes sense: the div with the long text is not dirty, so it doesn't get reflown...  Either we need to mark more stuff dirty here up front, or we need to do something smarter in block reflow when we realize that we're repositioning things so they're no longer impacted by floats.
Severity: minor → normal
Flags: blocking1.9?
OS: Mac OS X → All
Hardware: PC → All
Keywords: regression
Flags: blocking1.9? → blocking1.9+
Assignee: nobody → dbaron
This testcase is exhibiting extremely weird behavior on trunk: it renders correctly, except it doesn't show a horizontal scrollbar when it needs to.
Nevermind; my issue was just a result of sizing my window too narrowly.  The bug still exists as reported.
Depends on: 383883
Fixed by the checkin to bug 383883. I also checked in the testcase for this bug as a reftest.
Status: NEW → RESOLVED
Closed: 13 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.