Closed Bug 373396 Opened 15 years ago Closed 15 years ago

Preferences : 2 tabs in the redaction panel are too narrow

Categories

(Mozilla Localizations :: fr / French, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: flore, Assigned: bugzilla.fr)

Details

(Keywords: verified1.8.1.3)

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; fr; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Thunderbird Pre beta fr 2007030903

Preferences : Redaction panel -> General tab and addressing tab are too narrow. Sentences and buttons are not complete

And Pref window is not resizable on Mac.

Reproducible: Always

Steps to Reproduce:
1.Open preferences window
2.Go to Redaction panel and General or addressing tab
3.See that words and buttons are cut
Actual Results:  
Window too narrow

Expected Results:  
Window should be large enough to display all the text.
Attached image General tab too narrow
Flags: blocking-thunderbird2?
I have no mean to guess what the new window pref size should be as I have no Mac and as l10n cvs is frozen. Could someone give me the way to handle this, as I don't know if this is a blocker for TB 2.0 and we don't want to block or delay this release because of fr locale.
confirming, I see this to on a french mac build.

We haven't actually tagged the tree yet for tb2 so there's still time (albeit not much) to try to fix this if we can figure out the right size to use.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Cedric, I changed prefWindow.styleMac to 55em for french and while I can't read french, it looked to be the right width for the preferences dialog on the mac.

Flore, can you help me confirm my findings ASAP on your Mac? You can do this by: 

1) Creating a userChrome.css file in a directory called chrome in your profile: http://www.mozilla.org/support/thunderbird/edit#css
http://www.mozilla.org/support/thunderbird/edit#profile

2) Add the following style rule to userChrome.css:
#MailPreferences {
  width: 55em !important;
}

Thanks!
Attached patch the fixSplinter Review
I can land this before we tag if ya'll need help with this.
Scott, 55em is ok for the two tabs.
Thank you.
(In reply to comment #6)
> Created an attachment (id=258076) [details]
> the fix
> 
> I can land this before we tag if ya'll need help with this.
> 
Can I consider your answer as an approval to commit this on the branch which is frozen?
Comment on attachment 258076 [details] [diff] [review]
the fix

Please land this on the 1.8 branch as soon as possible for thunderbird 2. thanks. I can check it in too if you need me too.
Attachment #258076 - Flags: approval1.8.1.3+
Flags: blocking-thunderbird2? → blocking-thunderbird2+
Checked-in :
/l10n/l10n/fr/mail/chrome/messenger/preferences/preferences.dtd,v  <--  preferences.dtd
new revision: 1.3.2.2; previous revision: 1.3.2.1
done

I'll ask Flore to verify this with the next nightly.

Thanks mscott
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Awesome. Thanks everyone!
Keywords: fixed1.8.1.3
OK. Verified with build ID 2007031005
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.