event.relatedTarget is never set when leaving popup

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
12 years ago
2 months ago

People

(Reporter: gomita, Assigned: emaijala+moz)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-JP; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2 webaroo/1.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070308 Minefield/3.0a3pre

When I leave popup, mouseout event is fired but never have the relatedTarget on Trunk builds.
This makes impossible to figure out where I am after leaving popup.

Reproducible: Always

Steps to Reproduce:
1. Open the upcoming testcase.
2. Right-click to show popup.
3. Hover on popup.
4. Leave popup.
Actual Results:  
The textbox showing the relatedTarget for mouseout events are:
menuitem > popup > null

I get this result on Firefox 3.0a3pre.

Expected Results:  
The textbox showing the relatedTarget for mouseout events are:
null > menuitem > popup > page

I get this result on Firefox 2.0.0.2.

I don't know this bug is a regression on trunk build or not.
Reporter

Comment 1

12 years ago
Posted file Testcase
Reporter

Updated

12 years ago
Version: unspecified → Trunk
Assignee

Comment 3

12 years ago
The fix for bug 321098 made the Windows widget layer behavior consistent with Linux, and indeed this problem is also seen in gtk builds. I'd say this is a problem of event state manager. I'll try to see if I can find a way to fix it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee

Updated

12 years ago
Assignee: general → emaijala
Keywords: regression, testcase
Assignee

Comment 4

12 years ago
Roc, do you think we could do something like this? It fixes this problem and doesn't regress bug 321098, but would it cause something else to break?
Attachment #258949 - Flags: review?(roc)
If there's a menu showing, and the mouse is over a content document, and you move it into the menu, does the content document get a mouseout event with the menu content as the relatedTarget? I'm afraid it might. That would be very bad.
Assignee

Comment 6

12 years ago
No, in that case relatedTarget is null. I tested by adding 

onmouseout="handleMouseOut(event);"

to page in the test case.
Assignee

Comment 8

12 years ago
Apparently because the notification is done at <http://mxr.mozilla.org/seamonkey/source/content/events/src/nsEventStateManager.cpp#2700> and the target is never relayed there.
Reporter

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.