SVG image missing text on Windows; works fine on Mac or Linux

RESOLVED DUPLICATE of bug 305859

Status

()

defect
RESOLVED DUPLICATE of bug 305859
12 years ago
12 years ago

People

(Reporter: shepmaster, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

A simple SVG graph I made works perfectly in Firefox 2.0.0.2 Mac, but the graph label gets lost rendering on Windows. Little snips of the top of the text are visible, but nothing readable.

A screenshot of how it looks both on a mac and windows are linked below.
http://myxopho.be/~shep/fitness/mac.png
http://myxopho.be/~shep/fitness/windows.png

Reproducible: Always

Steps to Reproduce:
1.Load image in Firefox 2.0.0.2 Windows.

Actual Results:  
Image is missing text.

Expected Results:  
Image should have the text "Graph of body fat from 2007-03-01 to 2007-05-31"
Reporter

Comment 1

12 years ago
I found that using imagemagick to convert the svg to a png resulted in a similar problem with the text being cut off and just the top tips showing:

$convert bmi.svg imagemagick.png

http://myxopho.be/~shep/fitness/imagemagick.png

This still leaves the question of why the Mac render seems correct.
You are specifying the font-size in em units which we mozilla doesn't yet implement.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 305859
You need to log in before you can comment on or make changes to this bug.