deselect a calendar subscription -> no decrease of memory consume

RESOLVED INVALID

Status

Calendar
Provider: WCAP
RESOLVED INVALID
11 years ago
8 years ago

People

(Reporter: Andreas Treumann, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
REPRODUCTION:
=============

- subscribe a WCAP-calendar
- the consumption of memory increases
- deselect this subscription

RESULT:
=======

- no reduction of memory consume

EXPECTED RESULT:
================

- the consumption of memory goes down

REPRODUCIBLE:
=============

- always

Comment 1

11 years ago
Related to Bug 367456?

Comment 2

10 years ago
Please mind that WCAP currently caches (by default) the last 4 queries for 2 minutes to speed up toggling the views (aka in composite).
It's hard to judge on memory consumption and how much memory the js engine comsumes since garbage collection is non-deterministic. Looking at the WCAP code, I don't see an obvious leak.

Updated

10 years ago
Assignee: daniel.boelzle → nobody
Version: Lightning 0.3.1 → unspecified
(In reply to comment #2)
> Looking at the WCAP code, I don't see an obvious leak.

Has there been any change in the way WCAP works in the latest 0.8pre nightlies?

(This bug should be resolved accordingly if this isn't a valid issue)
I think we should close this bug. As Daniel mentioned, garbage collection is non-deterministic. We have many other perf bugs that should increase performance. This might go to the cost of memory, but memory is cheap these days.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.