Closed Bug 373720 Opened 15 years ago Closed 13 years ago

Bookmarks lost every time Firefox updates; Firefox updated without asking despite my prefs

Categories

(Firefox :: Bookmarks & History, defect)

2.0 Branch
x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED INVALID

People

(Reporter: abrams_les, Unassigned)

References

Details

(Keywords: dataloss)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

I have lost bookmarks before and now know how to retrieve them. But this time - you really out (Fire)foxed me. I did about 3 hours of online research and had about 30 bookmarks for that work. You updated my browser - even though I have set the options for you to ask first. When I came back on line a bit later - not only did you update without asking me - you lost that work that I had done - because you saved my bookmarks before I had done this work.

So you have really cost me this time and I am not happy about it. Either your software ignores the settings of my options regarding your asking first - or they do not work at all.

What to do - You have cost me dearly this time. I am working on a paper and all of my research is up in smoke. I am really angry.

That is my two cents worth.


Reproducible: Didn't try

Steps to Reproduce:
1.N/A
2.N/A
3.N/A
Actual Results:  
Cannot reproduce - is first occurrence in months of operating as I have been to restore the bookmarks when you update from the daily backups


Expected Results:  
did not perform any steps


Respected my wishes to NOT update unless I grant permission to do so.
I guess that I must seriously consider using another browser for my research. I am very angry and I cannot quite convey to you what you have cost me and how angry I am about it.
Severity: normal → critical
Version: unspecified → 2.0 Branch
Odd.  You seem to be experiencing two problems:

1. Whenever Firefox updates, your bookmarks are lost.  You managed to work around this with previous updates, but this time the backup was out of date.  It's interesting that this happens for you every time Firefox updates rather than being sporadic.  See bug 284099 and http://kb.mozillazine.org/Lost_bookmarks.

2. Firefox updated itself without asking.

If you're able to provide steps to reproduce, I'm pretty sure they would get fixed.  But as it is, we have no idea what caused the problems for you (these features work well for most users), and it's hard to guess :(

Btw, you might be able to recover some of your research time by looking in History.
Blocks: 284099
Keywords: dataloss
Summary: A different way to loose book marks → Bookmarks lost every time Firefox updates; Firefox updated without asking despite my prefs
My wife's Compaq computer has lost bookmarks for at least the last 3 times that Firefox updated, and I have restored them from the backups.  Prior to the last update, I had entered preferences that Firefox would NOT automatically update, but it did so anyway! (and bookmarks were lost yet again!)

My HP computer has exactly the same settings as my wife's Compaq, and the bookmarks have never been lost.  Consequently I suspect some unknown interaction with the alternate hardware.  But I don't know what to try differently.  Again, I emphasize that every single setting is the same on both computers.  Suggestions?
I have experienced this same situation.  I need a fix for it.  I have a ton of bookmarks that I would not be able to find again.  I too have my preferences set to not update automatically, but it did anyway.  Please let me know what can be done about it.
bookmark management is going to change in firefox 3.0, in the mean time (while you wait that someone can reproduce/fix your problem that is probably caused by a corrupt profile) try to use Foxmarks Extension to backup your bookmarks on an Internet Server. That should mitigate the dataloss problem
I also experience this problem. I have set firefox to not update automatically. I lose my bookmarks, and all my preferences are reset to the defaults. Strangely, my remember passwords remain intact. This happens with almost every update on two different machines. A dell Vostro 1400 and my custom build. XP home for the vostro and XP pro for my desktop. I use foxmarks and use the bookmark backups folder so that I do not lose data. But it is a real PITA to have to redo all my preferences after every update. Especially when I tell firefox to not update. 
On the previous occasion Firefox updated itself without prompting,(about this time last year) I lost all my emails, contacts, history and bookmarks. I kept pressing 'update later' this time (Firefox 200.2 or similar), but just a couple of days ago it updated itself again, without prompting. All bookmarks were lost (just the 200 or so needed for my work in education and hobbies etc!). Weirdly, Safari (which I haven't used for a year) had kept a lot of them!

Oh the nuisance of it all. There must be a secret hiding place to store this information so that it can be imported when updates are installed. If so, I'd be grateful to be told where and how.

Regards

Dave Mundy (davidgeorge71950@yahoo.co.uk)
THIS IS THE SAME **** THAT HAS HAPPENED TO ME THREE TIMES, FIREFOX UPDATE, AND WIPES OUT MY BOOKMARKS. HAVE NOT FOUND A WAY TO RETRIVE THEM. PLEASE FIX THIS PROBLEM.DON'T TELL ME THAT I CAN FIX IT BY UPDATING TO THE NEWEST FIREFOX. JUST FIX THE PROBLEM.I'M NOT THE ONLY ONE WITH THIS PROBLEM I SEE. SO FIX IT.
Places is enabled on all versions >= 3.0, bookmarks management on upgrade is different from 2.x, so i'm going to mark this as invalid since refers to upgrading between 2.x versions
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.