Allow components to register image content sniffers

RESOLVED DUPLICATE of bug 391667

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 391667
12 years ago
5 years ago

People

(Reporter: glandium, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
It would be neat if external components could register image content sniffers that would be called by imgLoader::SupportImageWithContents, so that external components could more easily add proper and full support for new image formats, such as MNG (#18574), DjVu (#241651), Jpeg2000 (#36351), or any other new format (one could think of MS's HD Photo) without the need to be incorporated in-tree.
(Reporter)

Updated

12 years ago
Severity: normal → enhancement
(Reporter)

Updated

12 years ago
Blocks: 18574
Duplicate of this bug: 374225

Updated

12 years ago
Blocks: 88020
bug 391667 added this functionality
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 391667

Updated

11 years ago
No longer blocks: 18574
You need to log in before you can comment on or make changes to this bug.