Closed Bug 374227 Opened 14 years ago Closed 14 years ago

Create a system for localizing basic installation strings

Categories

(Bugzilla :: Installation & Upgrading, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
Bugzilla 3.2

People

(Reporter: mkanat, Assigned: mkanat)

References

Details

Attachments

(1 file, 1 obsolete file)

There are times that we can't load the Template Toolkit, but we still want to display stuff, during installation.

Now that we have web-based installation, it would be nice to be able to output HTML where we can, and text when we can't.

Also, it would be nice for people to be able to localize checksetup messages.

Localization is the easiest, so we can start with that.

For pre-TT stuff, we'll have to have a very simple templating system. At first, we'll want something like this:

template/en/default/install/strings -- A file containing a hash that maps keys to plain-text strings.
Bugzilla::Install::Util::install_string($key) -- Returns the correct string for the current locale.
Attached patch v1 (obsolete) — Splinter Review
Okay, here's the templating code for pre-TT strings.

Eventually Bugzilla::Template should use the template_include_path subroutine here, inside of its own getTemplateIncludePath.

The only real problem I have with this system is that it doesn't cache the template_include_path, because I don't have any way to do that. I suppose I could write a manual cache that's like Bugzilla->request_cache. The problem is that I can't use Bugzilla.pm here.
Assignee: installation → mkanat
Status: NEW → ASSIGNED
Attached patch v2Splinter Review
Okay, I feel considerably more comfortable with this version. There's POD, a cache, and it's more taint-safe now.
Attachment #258838 - Attachment is obsolete: true
Attachment #258911 - Flags: review+
Checking in checksetup.pl;
/cvsroot/mozilla/webtools/bugzilla/checksetup.pl,v  <--  checksetup.pl
new revision: 1.549; previous revision: 1.548
done
Checking in Bugzilla/Install/Util.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Install/Util.pm,v  <--  Util.pm
new revision: 1.2; previous revision: 1.1
done
RCS file: /cvsroot/mozilla/webtools/bugzilla/template/en/default/setup/strings.txt.pl,v
done
Checking in template/en/default/setup/strings.txt.pl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/setup/strings.txt.pl,v  <--  strings.txt.pl
initial revision: 1.1
done
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Flags: approval+
Resolution: --- → FIXED
Keywords: relnote
Added to the release notes for Bugzilla 3.2 in a patch on bug 432331.
Keywords: relnote
Blocks: 467324
You need to log in before you can comment on or make changes to this bug.