Closed Bug 37435 Opened 20 years ago Closed 20 years ago

Replying to a message replaces some recipients with "undefined"

Categories

(MailNews Core :: Composition, defect, P3, major)

All
Windows NT

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mscott, Assigned: bugzilla)

References

Details

This just started happening within the last day. If you reply to a message with
multiple recipients and then send the message, some of the recipients are
replaced with the word "Undefined" and the message is not delivered to them.

Jean-Francois, this is the bug for the email I forwarded you from selmer.
data loss....marking as dogfood
Severity: normal → major
Keywords: dogfood
Do you have a reproducible case? how many recipients?
Status: NEW → ASSIGNED
Target Milestone: --- → M16
Ok, I can reproduce this bug. Investigating...
WORK AROUND:
Scoll the recipients list up to the bottom before sending the message and you 
wont see the problem.
*** Bug 37433 has been marked as a duplicate of this bug. ***
I think it's an XBL bug. Here is what appends:

when I query the textfield element for a row which is visible or have been 
visible, I receive an XBLBinding object, element.value return correctly the 
current content of the text field.

when I do the same on an element which has never been visible, I get a 
XULElement object, element.value return undefined. But 
element.getAttribute('value') return correctly the original content.

However, I cannot use element.getAttribute('value') on an element which is or 
has been visible because it return the original value, not the current content 
(in the case the user has edited it).
After all, it's maybe not an XBL bug but something to do with Hyatt's recent 
work for speeding up trees. David, any comment?
Here is my fix to go around the problem:

I use element.setAttribute{"value") = xxx AND element.value = xxx when I preset 
the field.

Index: addressingWidgetOverlay.js
===================================================================
RCS file: 
/cvsroot/mozilla/mailnews/compose/resources/content/addressingWidgetOverlay.js,v
retrieving revision 1.19
diff -r1.19 addressingWidgetOverlay.js
152a153,154
>               //We need to set the value using both setAttribute and .value 
else we will
>               // loose the content when the field is not visible. See bug 
37435
153a156
>           input[0].value = inputValue;
249c252,255
<           input[0].setAttribute("value", "");
---
>                       //We need to set the value using both setAttribute and 
.value else we will
>                       // loose the content when the field is not visible. See 
bug 37435
>                       input[0].setAttribute("value", "");
>                       input[0].value = "";
Fix in hand
Fixed and checked in. Should be in today's build.

How to test:

1) select a message with more than 3 recipients, including yourself
2) press button Reply All
3) wait for the compose window to finish loading and press the button Send
4) check the message sent that you have received.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
QA Contact: lchiang → esther
Using build 2000-05-10 on win98, mac and linux this is fixed.  Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.