Closed Bug 374822 Opened 13 years ago Closed 13 years ago

need a Firefox Windows debug + leak test tinderbox

Categories

(Webtools Graveyard :: Tinderbox, defect, P2, major)

x86
Windows XP

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: dbaron, Assigned: coop)

References

Details

Attachments

(1 file)

We need a debug and leak test tinderbox on Windows.  The configuration should be essentially the same as fxdbug-linux-tbox.

The trace-malloc leak test should currently work on Windows (I've tested the steps that it performs, although not actually running under tinderbox), although the info it gives about regressions won't currently be very useful (although I have a plan for fixing that).
Severity: normal → major
Priority: -- → P3
Trace-malloc now works on Windows, and the leak numbers on Windows would be by far the most useful since there's the least OS stuff getting in the way.
Any chance of raising the priority on this?  Windows is the most useful platform for the Lk test since the numbers are least confused by OS leaks there.
joduinn asked me to add this information to the bug: we already have debug+leak tinderboxes for Mac (bm-xserve11, added in bug 374823) and Linux (fxdbug-linux-tbox).
Assignee: build → ccooper
Status: NEW → ASSIGNED
Priority: P3 → P2
Cloning the tinderbox right now. Initial configs are in CVS on the test_mem branch.
Tinderbox is up (see MozillaTest), but the something in the test cycle is causing it to hang indefinitely. Debugging continues.
Success:

http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTest/1193154720.1193155792.4125.gz

Had an issue with the Time::HiRes.dll complaining about remapping and then crashing the scripts. Tried rebasing it but that didn't work. Since we don't really need HiRes on a non-performance box, I just moved the offending dll out of the way.

I've moved the tinderbox onto the main Firefox tinderbox tree and started up the continuous cycle.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
One more thing here:  the leak diffs aren't showing up, because of this code that was added here:

revision 1.145
date: 2002/03/13 08:04:28;  author: jrgm%netscape.com;  state: Exp;  lines: +99 -18
cls' changes to make this script work on win NT, and some additional changes from jrgm to work on win98. Additional work still needed to get some tests fully running, but cls has bloat stats working on winNT
----------------------------

I fixed the problems that would cause this to crash in bug 391491 (and maybe also some of the changes in bug 376874).
Attachment #285912 - Flags: review?(ccooper)
Attachment #285912 - Flags: review?(ccooper) → review+
Comment on attachment 285912 [details] [diff] [review]
remove disabling of --shutdown-leaks on Windows

Checked in.
Component: Tinderbox Platforms → Tinderbox
Product: mozilla.org → Webtools
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.