If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

should make assertions fatal on Firefox debug Mac OS X tinderbox

RESOLVED FIXED

Status

Webtools Graveyard
Tinderbox
P3
normal
RESOLVED FIXED
11 years ago
3 years ago

People

(Reporter: dbaron, Assigned: Waldo)

Tracking

(Blocks: 1 bug)

Details

Attachments

(1 attachment)

We need to change the configuration of the debug/leak-test Mac OS X tinderbox (proposed in bug 374823) on the Firefox tree so that assertions were fatal.  (We used to have a fatal assertions Linux tinderbox, but the configuration was changed, and then we regressed so that it would be orange if we turned it back on.)

I will mark things that need to happen before we do this as dependencies of this bug (although not necessarily immediately).
Depends on: 374828
Blocks: 279923
Depends on: 370875
Depends on: 362649

Updated

10 years ago
Priority: -- → P3

Updated

10 years ago
Depends on: 382194
bug 382194 currently seems to be the only assertion in the tinderbox logs.
Depends on: 394692
Depends on: 396761, 396833
Created attachment 281815 [details] [diff] [review]
Patch

This is a little early -- bug 396833 still needs to be fixed -- but I want to get this in as soon as possible after that fix so we can start catching regressions (like that bug!) as soon as possible before new ones appear, and that means I need review now instead of when that bug's fixed.

This URL says I modified the right file/branch:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1190368680.1190369130.22557.gz&fulltext=1

Is there a good way to make sure this change doesn't get lost if the tinderbox ever pulls its config from a different branch or something, or if it's replaced by a new one that pulls from a different branch without the fix?
Assignee: build → jwalden+bmo
Status: NEW → ASSIGNED
Attachment #281815 - Flags: review?(dbaron)
Comment on attachment 281815 [details] [diff] [review]
Patch

r=dbaron.  And yes, this looks like the test_mem branch to me.
Attachment #281815 - Flags: review?(dbaron) → review+
Fixed!
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

7 years ago
Component: Tinderbox Configuration → Tinderbox
Product: mozilla.org → Webtools
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.