Create toolbar items for Camino AppleScripts

VERIFIED DUPLICATE of bug 393050

Status

enhancement
VERIFIED DUPLICATE of bug 393050
12 years ago
12 years ago

People

(Reporter: peeja, Assigned: peeja)

Tracking

(Blocks 1 bug)

Details

Assignee

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.2pre) Gecko/20061230 Camino/1.1a1+
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.2pre) Gecko/20061230 Camino/1.1a1+

OmniOutliner generates a toolbar item for every AppleScript it finds in Library/Scripts/Applications/OmniOutliner.  This lets users easily customize the app by implementing commands they'd like to have in AppleScript and placing those commands on the toolbar.  Kinkless GTD (http://www.kinkless.com) is practically an application unto itself, implemented entirely as scripts in the toolbar.  I'd like to see a similar feature in Camino.

Disclaimer: This was originally Sam's idea.  Also, I'm including this bug as part of my Summer of Code proposal.

Reproducible: Always




Of course, this won't be very useful until we have better AS support going.
Since this is part of an SoC proposal, is there any reason not to confirm it? :)
Assignee

Comment 2

12 years ago
True.  :)

I filed this before the proposal was accepted, but since it's happening, confirming and taking.
Assignee: nobody → peter.a.jaros
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 393050

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.