APNG images not rendered.

RESOLVED DUPLICATE of bug 257197

Status

()

RESOLVED DUPLICATE of bug 257197
12 years ago
11 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3) Gecko/20070322 GranParadiso/3.0a3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3) Gecko/20070322 GranParadiso/3.0a3

None of the sample APNG images in http://littlesvr.ca/apng/ are rendered correctly.  The following happens for all of them, and http://littlesvr.ca/apng/images/012-dispose-none.png is just picked as a sample.

Reproducible: Always

Steps to Reproduce:
1. Navigate to http://littlesvr.ca/apng/images/012-dispose-none.png
2. Watch the browser window:
The image “http://littlesvr.ca/apng/images/012-dispose-none.png” cannot be displayed, because it contains errors.
Actual Results:  
The image is not rendered at all.

Expected Results:  
The image must be rendered, at least as a non-animated PNG.

about:buildconfig

Build platform
target
i686-pc-cygwin

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	14.00.50727 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	14.00.50727 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=beta --enable-optimize --disable-debug --disable-tests --enable-static --disable-shared --enable-svg --enable-canvas --enable-default-toolkit=cairo-windows --enable-update-packaging --with-branding=browser/branding/unofficial
(Reporter)

Updated

12 years ago
Component: General → ImageLib
Product: Firefox → Core
QA Contact: general → imagelib
Version: unspecified → Trunk
Version: Trunk → unspecified
Version: unspecified → Trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070323 Minefield/3.0a3pre
I see "0 1 2" (animated) with the latest normal hourly.
This was fixed some days ago.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 257197

Comment 3

12 years ago
The sample images won't work in 1.9a3 since there was a minor spec change that went in immediately after we reopened the tree for 1.9a4.
You need to log in before you can comment on or make changes to this bug.