Closed Bug 375257 Opened 14 years ago Closed 14 years ago

bug reassign fails with "Illegal mix of collations" after upgrading to 3rc1

Categories

(Bugzilla :: Creating/Changing Bugs, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 374951

People

(Reporter: jstaerk, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 

I have upgraded from 2.20 to 3.0rc1 with default upgrade proposal and left utf8 switched on (proposal of the upgrade). 



Reproducible: Always

Steps to Reproduce:
1.install bugzilla 2.20
2.insert some users and some bugs
3.upgrade to 3rc with default settings
4.choose any bug and try to reassign to sb else 
Actual Results:  
error message 
DBD::mysql::db do failed: Illegal mix of collations (utf8_general_ci,COERCIBLE) and (latin1_swedish_ci,IMPLICIT) for operation 'case' at /srv/www/htdocs/usegroup/bugzilla/process_bug.cgi line 1678


Expected Results:  
confirmation message that the bug has been reassigned

contrib/recode.pl --guess --charset=cp1252
does not help

switching unicode off works around the bug.
There seems to be many reports about this conversion to UTF8 when upgrading. We should make sure there is nothing wrong before releasing 3.0 final.
Flags: blocking3.0?
i volunteer to test if you have sth, to be honest, I did not even reproduce myself. if you like i can get myself a vmware snapshot with 2.22 and try to upgrade to 3rc1 (or is there a nightly version i'd better use?) and try to upgrade and reassign some bugs.
I'm guessing that at some point you did a mysqldump on the database without preserving the database charset?
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Flags: blocking3.0? → blocking3.0-
Resolution: --- → DUPLICATE
Duplicate of bug: 374951
you're right max, sorry.
You need to log in before you can comment on or make changes to this bug.