XBL bound partially in presence of Adblock Plus (intermittent)

RESOLVED WONTFIX

Status

()

Core
XBL
--
major
RESOLVED WONTFIX
11 years ago
10 years ago

People

(Reporter: Wladimir Palant, Unassigned)

Tracking

(Blocks: 1 bug)

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
I got several reports on this, all concerning Firefox 1.5 or Thunderbird 1.5 (no reports for Firefox 2.0 so I guess Gecko 1.8.1 is not affected). It is only a few people who see this issue. Firefox displays the message "No XBL binding for browser", Thunderbird fails to initialize the compose window properly. The cause is in both cases that XBL binding fails to apply properly - in case of Firefox it is the binding for the <tabbrowser> element, Thunderbird has issues with the binding for <editor>. DOM Inspector shows the binding, all the methods and properties from the binding are missing however.

A user gave me access to his computer, the problem could be reproduced reliably in his Firefox. I found out that for some reason the problem depends on the number of filters in Adblock Plus, a few filters less or a few filters more make it disappear. I can also see this problem in my Thunderbird 1.5.0.10 now where it is intermittent. Unfortunately I have to restart Thunderbird a dozen times to reproduce the problem so that determining which code in Adblock Plus triggers it is quite difficult.

I am certain that Adblock Plus doesn't block this binding - if it were blocked the results would be different. Adblock Plus generally doesn't do much here other than adding a few elements to the user interface. There is some initialization code triggered when the content policy object is instantiated the first time. This code will load the filters from a file and translate them into objects. These are not even used because the content policy returns early for all calls in case of Firefox - it checks nsIDocShellTreeItem.itemType and ignores chrome. So I have a strong suspicion that the number of filters is only relevant because we have a racing condition here.

Looking at XBL changes on the 1.8.1 branch that didn't manage it into the 1.8.0 branch it seems that bug 329410 is a likely to have fixed it. If my impression is correct, this patch forces chrome://global/content/binding/*.xml to load synchronously, something that hasn't been there before.
So... I can't seem to get Adblock Plus enabled in a Firefox off 1.8.0.x.

Do you build Firefox, by any chance?  If so, would you be willing to do a small experiment?
(Reporter)

Comment 2

11 years ago
Sure, but I only have a trunk debug tree at the moment. I won't be able to set up a new tree (1.8.0.x and optimized since I'm pretty sure it won't work in a debug environment) in the next few days. What do you have in mind?
Hmmm....  What won't work in a debug environment?  I was testing with a debug build.

I was wondering whether this is GC-related.  That is, whether adding "#define TOO_MUCH_GC" at the top of jsgc.h makes this appear even without Adblock Plus.

Another option would be to do a binary search on 1.8 branch nightlies to see when the problem disappeared, I guess... But you might be right about bug 329410 there.
(Reporter)

Comment 4

11 years ago
Thanks, I will try building Thunderbird (since I can sometimes reproduce this problem in Thunderbird) with this option. The problem seems to disappear after even slight changes, that's why I doubt a debug build will work, at least not with the same conditions. That's also why a binary search is difficult - if I cannot reproduce the problem in some nightly it doesn't mean that the problem is gone.
(Reporter)

Comment 5

11 years ago
Unfortunately the problem doesn't become reproducible in a build with TOO_MUCH_GC either. I only managed to reproduce it once and it was with Adblock Plus (couldn't make too many attempts obviously, the build is incredibly slow).

Comment 6

11 years ago
The "no XBL binding for browser" happens to me every time I start Firefox since upgrading to 1.5.0.12.  I do have adblock plus, but never had a problem before, and have never had a problem with thunderbird either (also 1.5.0.12).  I'm on OSX 10.4.10...

Comment 7

11 years ago
Wladimir in comment #4
> Thanks, I will try building Thunderbird (since I can sometimes reproduce this
> problem in Thunderbird) with this option. 

results?

(Reporter)

Comment 8

11 years ago
See comment 5.
(Reporter)

Comment 9

10 years ago
WONTFIX - Thunderbird 1.5 is no longer supported, also not by Adblock Plus.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
(Reporter)

Updated

10 years ago
Blocks: 467520
You need to log in before you can comment on or make changes to this bug.