Last Comment Bug 375564 - Remove ifdefs for 10.4 in Mac a11y code
: Remove ifdefs for 10.4 in Mac a11y code
Status: RESOLVED FIXED
[bk1]
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- normal (vote)
: mozilla10
Assigned To: Eitan Isaacson [:eeejay]
:
: alexander :surkov
Mentors:
http://bonsai.mozilla.org/cvsview2.cg...
Depends on:
Blocks: osxa11y
  Show dependency treegraph
 
Reported: 2007-03-27 10:45 PDT by Smokey Ardisson (offline for a while; not following bugs - do not email)
Modified: 2011-11-03 08:46 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove conditional compiles for pre-10.4 (4.91 KB, patch)
2011-11-01 07:09 PDT, Eitan Isaacson [:eeejay]
dbolter: review+
Details | Diff | Splinter Review

Description Smokey Ardisson (offline for a while; not following bugs - do not email) 2007-03-27 10:45:28 PDT
Bug 374362 fixed building Mac a11y in the default PPC config by just ifdefing the 10.4u SDK-only stuff, but Håkan noted the better way to fix it is to declare the constants ourselves.
Comment 1 Smokey Ardisson (offline for a while; not following bugs - do not email) 2007-03-27 10:47:39 PDT
Er, wrong blocks/depends; sorry :(
Comment 2 Smokey Ardisson (offline for a while; not following bugs - do not email) 2007-11-12 23:53:29 PST
Since the trunk no longer supports 10.3, we can just pull those ifdefs out; rather than closing this and filing a new one, let's just morph ;)

There are also some pre-existing self-defined constants in that file that can be un-defined now, too.
Comment 3 Håkan Waara 2007-11-13 00:30:38 PST
Sounds good to me, let's use the constants from Apple's headers as much as we can.
Comment 4 David Bolter [:davidb] 2009-06-16 11:49:19 PDT
Mass un-assigning bugs assigned to Aaron.
Comment 5 Eitan Isaacson [:eeejay] 2011-11-01 07:09:20 PDT
Created attachment 570987 [details] [diff] [review]
Remove conditional compiles for pre-10.4

I didn't try building this, someone should.
Comment 6 David Bolter [:davidb] 2011-11-02 11:08:45 PDT
Comment on attachment 570987 [details] [diff] [review]
Remove conditional compiles for pre-10.4

r=me
Comment 7 Marco Bonardo [::mak] 2011-11-03 08:46:21 PDT
https://hg.mozilla.org/mozilla-central/rev/5de05fbcdc67

Note You need to log in before you can comment on or make changes to this bug.