Closed Bug 375702 Opened 13 years ago Closed 13 years ago

Session restore dialog should have a "Safe Mode" button

Categories

(Firefox :: Session Restore, defect)

2.0 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 347680

People

(Reporter: glandium, Unassigned)

Details

It happens quite often, especially on linux, that plugins or extensions can be the reasons for a browser crash. It could be useful, for a lot of reasons, to have a "safe mode" option to the session restore dialog.
I'm not sure that we want to make the session restore choice at startup any more complicated than it already is (getting it wrong could be potentially disastrous). If you notice that your session is causing the crash, you can just launch into safe mode the normal way the second time.
Summary: Session restore should have a safe mode option → Session restore dialog should have a "Safe Mode" button
Actually, I'd prefer having a slightly cluttered session restore dialog than cluttering the "start menu" with a (99.9% of the time useless) "safe mode" item.
I don't really see what that has to do with this bug (and I disagree, FWIW).
It has to do that it is one reason to have the safe mode button there. You are free to disagree. I'm just one of those people who hate having 2 items for a program, one of them being useless 99.9% of the time.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 347680
You need to log in before you can comment on or make changes to this bug.