Problem rendering GIF with transparant background

RESOLVED DUPLICATE of bug 324698

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 324698
11 years ago
11 years ago

People

(Reporter: Yves Daemen, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a3) Gecko/20070322 GranParadiso/3.0a3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a3) Gecko/20070322 GranParadiso/3.0a3

I found this bug because of a website I made and in which I used some sort of spacer images. Anyway, the image of subject is a 1 pixel wide and 16 pixel high GIF image with transparent background and with 1 black pixel somewhere in the middle. I used it to make black lines with varying length using the style attribute (dirty, I know).

As you can see in the fore mentioned URL, the intensity of the line varies slightly, and isn't black at all. In all previous FF versions this is not the case. You can check for reference... The top image in the example is JPEG; just for reference view...

Reproducible: Always

Steps to Reproduce:
Surf to the URL and see for yourself...
Actual Results:  
The horizontally expanded image has a varying gray color along the line.

Expected Results:  
It should display a pure black line of 1 pixel high and 1000 pixels wide.

This is a clean install on a newly created user account on my Fedora Core 6 laptop. I also checked this on RHEL4 and it gives the same results.
(Reporter)

Comment 1

11 years ago
I think the same problem is messing up the layout of this website I made: http://www.asdservice.com (check in FF2 or older for reference)
Component: General → GFX: Thebes
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk
Sounds like a dupe of bug 324698 to me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 324698
You need to log in before you can comment on or make changes to this bug.