Closed Bug 375828 Opened 13 years ago Closed 13 years ago

RUN_AUTOCONF_LOCALLY doesn't regenerate configures after a CVS checkout conflict

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: neil, Assigned: neil)

References

Details

Attachments

(2 files)

Steps to reproduce problem:
1. Turn on RUN_AUTOCONF_LOCALLY
2. Make a change in your tree that will make a merge conflict
3. make -s -f client.mk checkout
4. Fix the conflict
5. make -s -f client.mk build

Expected results: configures are regenerated

Actual result: configures are not regenerated
Attached patch Proposed patchSplinter Review
Because the configure.in could be conflicting we can only delete the configures and then regenerate them later on demand. This has the added benefit that make -s -f client.mk build will regenerate the other configures.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #260004 - Flags: review?(benjamin)
Comment on attachment 260004 [details] [diff] [review]
Proposed patch

How is this going to work, since the ldap code uses autoconf2.5x, while mozilla/nspr use autoconf 2.13? and... configure should conditionally depend on directory/c-sdk, because that directory is only pulled when we pull mailnews.
Attachment #260004 - Flags: review?(benjamin) → review-
Comment on attachment 260004 [details] [diff] [review]
Proposed patch

(In reply to comment #2)
>How is this going to work, since the ldap code uses autoconf2.5x, while
>mozilla/nspr use autoconf 2.13?

>-ifdef RUN_AUTOCONF_LOCALLY
>-       @echo Generating configures using $(AUTOCONF) ; \
>-       cd $(TOPSRCDIR) && $(AUTOCONF) && \
>-       cd $(TOPSRCDIR)/nsprpub && $(AUTOCONF) && \
>-       cd $(TOPSRCDIR)/directory/c-sdk && $(AUTOCONF)
>-endif
I'm just copying what this does. If client.mk shouldn't remove and regenerate the directory/c-sdk configure then that's hardly within the scope of this bug.

>and... configure should conditionally depend on
>directory/c-sdk, because that directory is only pulled when we pull mailnews.
No, it's pulled unconditionally. My fault for not showing enough context.
Attachment #260004 - Flags: review- → review?(benjamin)
Attachment #260004 - Flags: review?(benjamin) → review+
Fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
This broke my local build because /directory/c-sdk/configure is not pulled unconditionally.  The LDAPSDK_CVSCO command is cleared if /directory/xpcom/ is not in the build.
Yep, this broke the remaining l10n tinderboxens on trunk, see http://tinderbox.mozilla.org/Mozilla-l10n/.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached patch Bustage fixSplinter Review
Thanks for pointing that out. I checked this in to fix the l10n bustage.
OK, l10n is turning green.
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
Blocks: 433354
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.